1

I'm running ubuntu 14.04 on a virtual box within a windows 8 host machine. I've had the misfortune of stumbling upon the dreaded ubuntu 14.04 login loop after a sudo apt-get upgrade command, and have tried all suggestions (checking .Xauthority, reinstalling lightdm, installing alternative desktop programs, etc...) and the only approach that has actually worked was to add a new user (with superuser privileges). Unfortunately, this only works once... After I reboot the computer, the login loop resumes and the newly created user no longer allows me to login successfully. Everytime I reboot, I need to add a new user with superuser privileges in order to login successfully.

So, I have two questions:

  1. Why does adding a new user work at all (even if only once)? What exactly is it temporarily fixing.
  2. The fact that the login loop resumes after reboot on the newly created user is a symptom of a deeper problem, imho. What exactly is the deeper problem and how can I fix it?
  • after you added newuser did you give it root access & save it Ctl-X,y,Enter ? – DnrDevil Jan 18 '16 at 2:00
  • @DnrDevil: Of course i did! Doing so does not solve the problem. – Paul Jan 18 '16 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.