1

We just received a WorkCenter 3615 printer in the Lab and I'm trying to use in the local network under Ubuntu 14.04.

I am not totally sure that the problem is with the driver (but it is the most probable)

I found the printer in the list of Network Printers and I downloaded and installed (with Ubuntu Software Center) the driver Linux Intel Driver .DEB x86_64 from the official page. In the new printer setup process, phase Choose Driver, the online search fails and if I choose Select printer from database, then the recommended is an other one (X. WC. 3119) and there is no driver for our printer 3615. I tried this driver, but when I print the test page, prints on a lot of pages strange characters.

I can't find online any ppd file for this printer, in the windows drivers there is only one zip file and it is just for the scanner and does not contain the ppd.

Am I doing something wrong with the installation? Is there any workaround?

1 Answer 1

0

I'v read that the official driver and ppd file is broken, but I found a working PPD at this page.

I added the printer and set the driver through ppt file from the source above and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .