2

I just discovered this bitter truth: my curl doesn't support sftp.

~ curl --version
curl 7.43.0 (x86_64-pc-linux-gnu) libcurl/7.43.0 GnuTLS/3.3.15 zlib/1.2.8 libidn/1.28 librtmp/2.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp 
Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz TLS-SRP UnixSockets 

What'd be the reason to castrate such a useful tool? Am I supposed to recompile the package on my own or can I consider this as a "bug"/"enhancement" to be filed?

1

There is already a bug. This was a problem inherited from Debian, but then it was solved there (in Debian).

And now apparently everything gets down to a problem with repositories (curl is in main while the needed libraries are in universe, and this goes against the policies for the main section).

If you want to recompile it I suggest you to follow this answer on this website.

  • 1
    Recompilation is not an option in my opinion. cURL (and libcURL) are not secondary or little known packages. Moreover, manual compilation could/would require user care for subsequent updates/upgrades. – EnzoR Jan 12 '16 at 17:48
0

This seems to be another "dust under the carpet" situation like @dadexix86 hinted.

There's a question with a trivial answer : recompile it!

There's a bug filed to Debian (Ubuntu's upstream) with a fix released 4+ years ago.

There's still no solution for Ubuntu users other than the recompilation one, that get's wiped with the next libcurl upgrade, unless you stick with an old locally recompiled version.

So, no real answer is possible here, only a partial and temporary workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.