To give you a little background: I am currently running on Ubuntu 14.04 LTS and want to use the application pan newsreader. Unfortunately if I install that via the Ubuntu Software Center, I get pan 0.139-2, which crashes, when I run it.

[GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name news.pan.NZB
was not provided by any .service files
ERROR:pan-tree.cc:80:GtkTreeIter PanTreeStore::get_iter(const
PanTreeStore::Row*): assertion failed: (row)
Aborted (core dumped)]

So I decided to install a development build from source code.

So I went: git clone git://git.gnome.org/pan2

and after some problems I got ./autogen.sh; make to work. I rebooted several times in between these things and now the application seems to be set up properly.

The executable to open should be /pan2/pan/gui/pan.

I tried *rightclick run, but nothing opened. If I enter pan in the terminal, I am told to download pan 0.139-2 (The version that crashes). Due to lack of understanding basically how a computer works, I then went: cd ~/pan2/pan/gui and then entered ./pan.run, which I read up somewhere on the internet, but it said there was no such file in that directory.

Every advice is greatly appreciated!



  • did you do make install? – Olimjon Jan 7 '16 at 8:10
  • Sadly Pan2 is not much developed nowadays... latest version 0.139 (still says beta) was in the Ubuntu repositories for ages... so installing from source won't help. For me the previous version 0.139-0 (available from 12.04 precise) worked better. To prevent upgrades see askubuntu.com/questions/18654/… – Takkat Jan 7 '16 at 8:18
  • Did you make that file /pan2/pan/gui/pan executable ? Do chmod +x /pan2/pan/gui/pan and then try to run it – Sergiy Kolodyazhnyy Jan 7 '16 at 9:48

@Olimjon: You were right; i did not yet do make install, because i thought the ;make before did that, but anyway.

And Takkat was right, too. After that I got the same error.

Now I want to install version 0.139-0 as you did. The easiest way to do that seems to be: How to downgrade packages on Ubuntu?

Unfortunately I only have version 0.139-2 in my repositories. Which repositories do I have to add to be able to install version 0.139-0?

Thanks to everyone!


you must get build-essentials ,gcc and cmake packages first.

sudo apt-get updat && sudo apt-get install -y build-essential gcc cmake

after that , goto the program directory you have excuated , and write

sudo cmake configurationfilename

and then

sudo make

sudo make install

best regards,

  • please add sudo in cmake and make – Ahmed Al-attar Jan 7 '16 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.