2

I have set my NTFS partition for auto-mount in Ubuntu 15.10 using the GUI utility as follows - Auto-mount settings

All the options provided are the defaults options.

After I restart, the partition is automatically mounted. But the "Move to trash" option is missing when I right click on a file.

Is there any way to fix this by using the window as given in the image above, without having to alter the rules by myself as mention in this page Cannot move file to trash warning when trying to delete a file in Nautilus since I'm not good in doing it?

0

Don't forget to adapt /home/user/shared to your scenario. It is the place where your NTFS partition is mounted. Please note that the directory you specify must exist already, if not create it. It can be anywhere, but in the home folder it is easily accessible. So if your username is "bart", a good location would be /home/bart/ntfs:

sudo mkdir /home/bart/ntfs

As you are saying you use an auto mount, you probably have a fixed location already (so the above command is unneccesary).

Creating a trash, GUI method

You can do this in GUI by adding uid=1000 to the options just above mount point. Don't forget the comma :). Do a reboot to let this take effect.

Creating a trash, CLI method

  1. Open /etc/fstab with an editor, for example gedit:

    sudo gedit /etc/fstab
    
  2. Now add the option "uid=1000" to the NTFS mount line (something like this):

    /dev/sda3 /home/user/shared ntfs defaults,uid=1000,noatime 0 0
    

This will make you the owner and should create a .Trash-1000 folder where deleted files will be placed.

  1. Once you have saved the fstab file, umount and remount the partition (or reboot your computer):

    sudo umount /dev/sda3 && sudo mount -a
    

Source: http://ubuntuforums.org/showthread.php?t=1499345

  • 1
    What if I want to set it through the GUI as should in the image above, without changing the fstab by myself. And the trash directory is already there. – Hepkhatduh Jan 7 '16 at 8:48
0

I had the same problem. I owned the Trash folder, so that was not the problem. This worked for me:

Edit /etc/fstab or use gnome-disks so that the mount is not auto. Mount with both of the following:

  1. File system must be ntfs-3g
  2. Option uid=1000 must be used.

My fstab has it like this: LABEL=HOME /mnt/HOME ntfs-3g nosuid,nodev,nofail,x-gvfs-show,uid=1000 0 0

Note:

  • Mounting as "ntfs" did not work
  • Mounting as ntfs-3g without uid=1000 did not work.

Must do both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.