2

More often than not, when my laptop is resumed after being suspended, the fan will no longer spin, resulting in overheating when a heavy process is running.

This happens on Ubuntu 14.04 with 3.13.0 and 3.19.0 kernels.

I had no fan problems on Ubuntu 12.04 with a 3.5.0 kernel.

A reboot (soft or hard) always starts the fan again.

Something which sometime works:

  • Shutting the lid and waiting for some time. When I return and unsuspend the machine, and make it hot, sometimes the fan will start working again!

    (Although then it never stops spinning, even when the temperature drops low.)

Things I have tried which have no effect:

  • sensors-detect from the lm-sensors cannot find anything beyond coretemp
  • fancontrol service does not start because pwmconfig finds nothing to work with
  • Kernel options acpi_osi=Linux, =Windows and ='Windows 2015'
  • acpi=off caused the machine to boot with no fan and various other stuff missing
  • Flashed the BIOS to latest firmware
  • Installed latest intel-microcode package

Sensors:

  • sensors lists three temperatures but no fan speeds.

  • acpi -ci lists three entries (intel_powerclamp, and two processors) but the values rarely seem to coincide with what I'm hearing

Question:

  • What else has changed that I could try disabling, either changes in the kernel since 3.5.0, or in Ubuntu between 12.04 and 14.04?

Edit: One other thing about my system. When moving from 12.04/3.5.0 to newer kernels, I had to go into the BIOS and change "OS Selection" from "Windows 8" to "Windows 7" in order for bootup to complete.

2
+125

This should work. Create /etc/pm/sleep.d/20_fancontrol with the following contents:

#!/bin/sh

case "${1}" in
    resume|thaw)
      /usr/sbin/service fancontrol restart
      ;;
esac
| improve this answer | |
  • Thanks for the suggestion. Unfortunately this does not help because fancontrol doesn't work here: neither sensors-detect nor pwmconfig could find drivers to control my hardware. Under Ubuntu 12.04 I also didn't have fancontrol installed, but the fan did stay working after suspend! – joeytwiddle Jan 12 '16 at 1:09
  • 1
    Have you tried latest upstream kernel? – Håvard Pettersen Jan 12 '16 at 12:32
  • No you dont that is the point of: '#!/bin/sh' – Håvard Pettersen Jan 16 '16 at 17:02
  • Yep, I'm now on 4.2.0-27-generic. – joeytwiddle Feb 5 '16 at 3:21
  • 4.4 kernel seems to have got fancontrol working, and the problem has now resolved! To get it I installed the package linux-image-lowlatency-lts-xenial. Both 4.4.0-14-lowlatency and 4.4.0-22-lowlatency have worked fine. – joeytwiddle May 30 '16 at 13:04
1

Have you tried acpi_osi="!Windows 2012"? acpi_osi string "Windows 2012" was introduced after 3.5 so disabling it can bring you back to how kernel works with ACPI as in 3.5.

| improve this answer | |
  • Thanks. That was actually in my list of things to try, but I haven't tried it yet. It will be my next experiment, and I will let you know next week whether it has worked or not... – joeytwiddle Jan 14 '16 at 5:13
  • Well this certainly disabled something: dmesg | grep Windows shows me ACPI: Deleted _OSI(Windows 2012). But unfortunately the bug persists. However you have reminded me of a change I made to the BIOS when I upgraded. I have appended this to the question, and in time I will test whether it is actually part of the problem. – joeytwiddle Jan 16 '16 at 16:34
  • Unfortunately the behaviour was no different with this kernel option. – joeytwiddle Feb 5 '16 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.