0

Hi all and happy new year.

Today, I update my Xubuntu installation and after reboot I can't boot anymore. Screen says:

Failed to open \EFI\BOOT\grubx64.efi - Not found Failed to load image \EFI\BOOT\grubx64.efi: Not found Failed to open \EFI\BOOT\MokManager.efi - Not found Failed to load image \EFI\BOOT\MokManager: Not found

and then a message asking for a bootable disk. I try different methods to fix the problem, like this post or this, but the problem persist.

After that, I use boot-repair and perform the recommended repair. After a successfully boot repair, I reboot the PC but the problem persist. Here is the complete report: http://paste.ubuntu.com/14422731/

I appreciate any help. All the best,

Christian.

An update: Using SuperGrub disk I can able to find this error: Faild to mount /boot/efi, type S to skip it, or type M to fix it manually. M put me in a console for repair and S proceed, with some error, in boot.

Since the system was unable to mount nothing in /boot/efi, I try to mount manually: sudo mount /dev/sda1 /boot/efi and the error was: mount: wrong fs type, bad option, bad superblock on /dev/sdc1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

So, I run dmesg | tail and found this message: [ 510.816445] FAT-fs (sdb1): IO charset iso8859-1 not found

To check the media, I run a fsck.vfat on /dev/sdb1 and nothing look wrong: fsck.fat 3.0.26 (2014-03-07) /dev/sdb1: 691 files, 4632/130812 clusters

So...a bug in the last kernel update?

Greetings, chq

  • 1
    Post an answer to your own question and accept it if you found a solution. DO NOT just edit your title to say solved. – Thomas Ward Jan 7 '16 at 20:57
  • As Thomas W. said please don't put "SOLVED" in the title. Also could you post the solution you included in the question as an answer to the question instead of including it in the question itself? Thanks. – kos Jan 7 '16 at 21:00
0

Finally I found a solution:

  1. Enter with a live Xubunto usb-disk
  2. Thinking in a probable bug when update from kernel 3.13.0-43 to 3.13.0-74, using gparted, I reformat sdb1 and flag as boot partition
  3. I reboot and re-enter with SuperGrub usb-drive to my sdb2 system with the 3.13.0-74 kernel.
  4. I mount efi running sudo /dev/sdb1 /boot/efi without problems and then install grub using sudo grub-install --bootloader-id xubuntu /dev/sdb
  5. Before reboot, disable quiet splash
  6. While reboot a message say /boot/efi not found appears, but still can boot pressing S. I compare the UUID of fstab and blkid and ofcourse, after remove and recreate boot partition, id was not the same. So, I remove the old line from fstab and reboot.

Voila...it's work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.