I have horrible problem which is on my nerve :( It started to happen when I changed its shortcut from Ctrl + Alt + Left/Right arrows to Ctrl + Alt + 1/3 since it had conflict with my Android Studio.

This new assignment (shortcut) works fine and I'm able to switch between left and right workspaces. However, by switch to each workspace, its active window sticks to right corner of screen.

  • For sake of visual explanation, let say this is screenshot of my screen.

enter image description here

  • Now, I switch to right workspace by Ctrl + Alt + 3
  • Then again I switch back to left workspace by Ctrl + Alt + 1
  • My screen looks like this

enter image description here

Same thing happens for active window on second workspace. Any idea would be appreciated. Thanks.

1 Answer 1


If you are using the numpad keys, which are different than the number keys above the keyboard (and to which the shortcut you tried to set actually likely refers), then what happens is this:

bottom right number on the numpad is 3, therefore ctrl+alt+3 will focus that window to the bottom right of the page.

following that pattern, 1 is bottom left corner, 7 is top left corner, 9 is top right, 8 is top half, 2 is bottom half, 5 is full screen, etc.

These shortcuts are viewable in the 'grid' section of the compiz settings manager.

  • thanks. yup, I found the issue and changed my shortcut. Thanks for answering the question.
    – Hesam
    Jan 14, 2016 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.