0

I am trying to install wine on Ubuntu 15.04, I had it working before but I think something went wrong with 32 or 64 bit installations so I tried removing it to start again.

Now I am trying to install it again but running apt-get install wine

root@pc-ubuntu:/home/dav# apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 wine : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages`

So I try to fix the broken packages with apt-get install -f

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.`

I have tried removing and adding the PPA, I have tried a load of other commands pointed out in the answer here How do I resolve unmet dependencies after adding a PPA? But none of them have worked either. I'm stuck, please any suggestions would be amazing to fix this as I would like to sort it before attempting to build the latest wine 1.8 from source. Thanks

7
  • Can you remove any package without dpkg --force?
    – Olimjon
    Jan 7 '16 at 0:20
  • Yes, no problem... root@pc-ubuntu:/home/dav# apt-get remove ppa-purge Reading package lists... Done Building dependency tree Reading state information... Done The following packages will be REMOVED ppa-purge 0 to upgrade, 0 to newly install, 1 to remove and 2 not to upgrade. After this operation, 45.1 kB disk space will be freed. Do you want to continue? [Y/n]
    – Dav
    Jan 7 '16 at 0:26
  • Sorry, don't know how to format the comments nicely
    – Dav
    Jan 7 '16 at 0:27
  • Try apt-get dist upgrade and send the results
    – Olimjon
    Jan 7 '16 at 0:35
  • that outputs root@pc-ubuntu:/home/dav# apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade. So no problems there either...
    – Dav
    Jan 7 '16 at 0:41
1

None of your packages are broken. The wine dependencies are conflicting with each other. Uninstall existing version of wine (if exists) then install wine1.7 (there won't be such problem with wine1.7)

UPDATE: To install wine 1.7 on your case type these in your terminal:

sudo apt-add-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.7

6
  • There is no version installed, apt-get remove wine shows nothing to do. So do I simply run apt-get install wine1.7?
    – Dav
    Jan 7 '16 at 15:30
  • Yes, I said uninstall if exists.
    – Olimjon
    Jan 7 '16 at 21:23
  • Coming up with the same problems. root@pc-ubuntu:/home/dav# apt-get install wine1.7 Reading package lists... Done Building dependency tree Reading state information... Done Package wine1.7 is a virtual package provided by: winehq-staging 1.9.0~ubuntu14.04.1 winehq-devel 1.9.0~ubuntu14.04.1 You should explicitly select one to install. E: Package 'wine1.7' has no installation candidate. When I try to install winehq-staging or winehq-devel I get the original errors about holding broken packages
    – Dav
    Jan 9 '16 at 14:01
  • You should explicitly select one to install. root@pc-ubuntu:/home/dav# apt-get install winehq-staging Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies. winehq-staging : Depends: wine-staging but it is not going to be installed E: Unable to correct problems, you have held broken packages.
    – Dav
    Jan 9 '16 at 14:06
  • I will update the answer.
    – Olimjon
    Jan 10 '16 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.