So, just installed 14.04 on dual boot with Windows 10.

Pleasantly surprised that installation went without a hitch but when I first booted there were no drivers for my USB wifi adaptor (NetGear WNDA3100).

No problem I thought.. I'm sure I played this game in the dim and distant past.

Found the driver I need (bcmn43xx64.inf). now just need to install ndiswrapper.

It shows up in the program manager as available from a "universal source", but having no internet that's not much help.

Reading a few forums it seems that it might be on the installation DVD. It isn't.

I manage to find files online including:


most seemed to install in the program manager except one which insisted on me inserting my DVD ?!?! I did this anyway and it still refused to install.

There was no obvious way to try running it other than through the terminal so I tried ndiswrapper -V. A load of info about bits being missing and out of date.

I'm pretty much at the point of giving up. Surely it can't be this hard?

Any help would be most gratefully received.

Edit to add:

sudo dpkg -s ndiswrapper-common      Install OK
sudo dpkg -s ndiswrapper-utils-1.9   Install OK

Other information:

lsusb - 0846:9011 Netgear, inc.  WDNA 3100V2 [Broadcom BCM4323]

Am trying to use "bcmn43xx64"

ndiswrapper -l shows it listed as installed but not working / error state.

Edit No.2

Managed to uninstall the invalid driver and have reinstalled with the same file from a different source.

Running ndsiwrapper -l it now shows the driver as functional and the hardware as present.

My only remaining question is how do I get Ubuntu to recognize it? I have tried rebooting and it isn't appearing. Is there a set up wizard I can run or will I need to do some kind of manual set up?

Any help appreciated :)

Edit 3.

Still no luck getting this to work. Nothing is "appearing" to let me use the hardware.

The only other clues are from ndiswrapper -V which says the following:

modinfo: ERROR: module ndiswrapper not found. Module version is too old.
Utils Version: 1.9, Utils version needed by module '0'
Module Details: Modinfo ERROR: Module ndiswrapper not found.

None of that looks particularly healthy and I assume is somehow linked to the problem.. though I have no idea what any of it means.

  • Please edit your question to add the result of this command from the terminal: sudo dpkg -s ndiswrapper-common | grep Status and also: sudo dpkg -s ndiswrapper-utils-1.9 | grep Status If those two are installed correctly, we can proceed. Welcome to askubuntu. – chili555 Jan 6 '16 at 22:01
  • Thanks Chili, will do. I think they may be at least partially installed now because I ran ndiswrapper -L and it listed bcmn43xx64.inf but stated it was not working. I'm not sure how to do screen dumps but I'll try to get that other info for you now. – Libs Jan 6 '16 at 22:11
  • Updated as requested :) – Libs Jan 6 '16 at 22:25
  • Making some progress. I have managed to uninstall the driver that didn't work. I have downloaded another one and installed that. – Libs Jan 6 '16 at 23:00
  • On installation I got a message "couldn't find source disk files section.. continuing anyway".. I don't know what that means but when I run ndiswrapper it says the driver is ok and the hardware is found. – Libs Jan 6 '16 at 23:02

It doesn't look like NDIS wrapper kernel module was installed successfuly. Make sure you installed the DKMS package for NDIS wrapper, that you can find here: http://packages.ubuntu.com/trusty/ndiswrapper-dkms (also, meet packages.ubuntu.com where you can download all the packages that Ubuntu provides directly without 3rd parties or trawling through FTP sites).

After you install the DKMS module, it should report something like this:

Setting up ndiswrapper-dkms (1.59-2) ...
Loading new ndiswrapper-1.59 DKMS files...
First Installation: checking all kernels...
Building only for 3.19.0-26-generic
Building initial module for 3.19.0-26-generic

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.19.0-26-generic/updates/dkms/


DKMS: install completed.

Then sudo modprobe ndiswrapper should succeed.

After that, ndiswrapper -v should say something like:

utils version: '1.9', utils version needed by module: '1.9'
module details:
filename:       /lib/modules/3.19.0-26-generic/updates/dkms/ndiswrapper.ko
version:        1.59
vermagic:       3.19.0-26-generic SMP mod_unload modversions 

(your version numbers will probably be different, I'm running 15.04 vivid)

Then you should try to reinstall the driver using ndiswrapper -i.

Finally, all this may not be needed - Linux has a driver specifically for Broadcom USB wireless adapters called rndis_wlan. As detailed here. If when you plug the device, the rndis_wlan driver is not loaded automatically (you can check by running lsmod | grep rndis), then try to load it manually using modprobe rndis_wlan and it may detect and enable your device. If not, run dmesg | tail to check for kernel errors and report them here.

Another thing to note, is that if you can't get your wireless to work, then its often easy to just plug the computer to a wired network and do all your troubleshooting with full network access - which will allow you to apt-get packages.

  • Thanks Guss. I managed to installed the DKMS module from your link. (I tried before but the reason it directed me to the installation DVD was that I was missing a dependency. Found it and installed it and both seemed to install ok. I ran the command sudo modprobe ndiswrapper and nothing seemed to happen either good or bad. I tried to re load the driver but it said it was already loaded. There still doesn't seem to be anything happening though. – Libs Jan 8 '16 at 15:38
  • No internet :( Also, this is a desktop device and my router is on the other side of the house so no easy way to run a LAN. I think I may have to just give this up as a bad job and maybe buy a simple PCIe network card that Ubuntu can handle natively :( – Libs Jan 8 '16 at 15:39
  • Did you try rndis_wlan? – Guss Jan 8 '16 at 16:37
  • Thanks for your help Guss, I didn't try rndis_wlan but my new wireless card has just arrived and just auto-recognised on first boot. I'm now writing from Firefox in Ubuntu. I'm going to give up on the USB wireless for now.. but again, thanks for trying to help me get up and running. Really appreciate your support :) – Libs Jan 10 '16 at 10:14
  • Sure, and I do recommend you update to a non-LTS release. Alternatively, you can hold on to 14.04 until the next LTS release comes out in April. – Guss Jan 10 '16 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.