Having problems running Openstack-Install, using MAAS and Autopilot. Getting error Problem with juju bootstrap. Complete .cloud-install/commands.log file: http://pastebin.com/ANBMZwLs

It deploys a node, and fails after about 1500 sec. From the logfile it seems its not reaching some archives? But I am able to run apt-get update on both the deployed node over ssh, and the MaaS server it self.

I have two networks, one public( and one private for the nodes (, MAAS server is acting as proxy for the Nodes.

Any help much appreciated


In your selected network architecture, private network(your nodes) must have access to Internet, and it seems in yours do not have access to Internet.

You must enable nat on your region controller following instructions in this link https://help.ubuntu.com/community/Internet/ConnectionSharing

1. step one - considering private network connected to eth1:

sudo iptables -A FORWARD -o eth0 -i eth1 -s -m conntrack --ctstate NEW -j ACCEPT
sudo iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
sudo iptables -t nat -F POSTROUTING
sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

2. Save the iptables:

sudo iptables-save | sudo tee /etc/iptables.sav

3. Edit /etc/rc.local and add the following lines before the "exit 0" line:

iptables-restore < /etc/iptables.sav

4. Enable routing Configure the gateway for routing between two interfaces by enabling IP forwarding:

sudo sh -c "echo 1 > /proc/sys/net/ipv4/ip_forward"

5. Edit /etc/sysctl.conf and uncomment:


... so that it reads:


Regards Sajjad

| improve this answer | |
  • Yes, you are right. It was missing IP Forwarding that was the issue, though I followed a different guide to accomplish this, but will try your suggestion soon, as I am reconfiguring the whole setup. If I succeed, I will mark you answer as correct. – ladrua Jan 9 '16 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.