4

Only when I'm closer to the router, it shows any signal, but when I'm just little far from it, it is not showing wifi routers signals.

  • Let me guess, is it a HP laptop? – Jeremy31 Jan 6 '16 at 15:33
  • Yes.. HP Laptop !! – Swapnil Sharma Jan 6 '16 at 17:55
  • Is it easy to access the wifi card? – Jeremy31 Jan 6 '16 at 18:11
  • Yup ... There's no another error, only that I mentioned above.. And I almost try all the solution present in the internet... but no one method can able to solve this problem... – Swapnil Sharma Jan 6 '16 at 18:50
  • I mean physical access, is it easy to replace? Some HP laptops require major disassembly to get to the wifi card – Jeremy31 Jan 6 '16 at 23:40
9

With Ubuntu 16.04 and later, go to Parameter settings as nothing needs to be downloaded

Progress from Larry Finger from here

If you installed rtlwifi-new-dkms from Pilot6's PPA, it will need to be removed with

sudo apt-get remove rtlwifi-new-dkms
Reboot, then


sudo apt-get install git build-essential
git clone https://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new
make
sudo make install

Reboot and then

Parameter Setting

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=1

Test wireless, if no change then

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2

Test wireless again, one or the other should result in better reception

When you find that one works better than the other

echo "options rtl8723be ant_sel=X" | sudo tee /etc/modprobe.d/rtlbtcoex.conf
Where X is 1 or 2- whatever resulted in better performance, in the case of Swapnil Sharma it would be
echo "options rtl8723be ant_sel=1" | sudo tee /etc/modprobe.d/rtlbtcoex.conf
Then the parameter will be remembered following a restart

  • 1
    Thanks it works. But not Completely. I have to use this again and again after restarting my Laptop. sudo modprobe -rv rtl8723be sudo modprobe -v rtl8723be ant_sel=1 – Swapnil Sharma Jan 26 '16 at 8:57
  • WOW... This actually works... seems to have worked for my Realtek RTL8188EE WiFi driver. Thank you so much @Jeremy31 ! This issue was really starting to bother me. – Robin Hood Mar 20 '18 at 14:00

protected by Community Oct 26 '16 at 19:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.