I just installed Ubuntu 11.10.

I changed the open drivers for the proprietary ones and had all sorts of problems while trying to make dual screens work, so I decided to roll back the drivers.

Now Unity won't start and if I run /usr/lib/nux/unity_support_test -p I get:

/usr/lib/nux/unity_support_test: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

I tried mostly everything that was suggested on the net with the purge and everything. Installing ccsm and adding the Unity plugin did not work. I also just learned about that missing file while writing this question, so thats where I'm heading now.

If you need more info just say so.

  • Could you elaborate on what you mean by "that missing file"? Oct 25, 2011 at 6:16
  • I meant the file from the error message I receive when running unity_support_test -p : libGL.so.1
    – jfabre
    Oct 25, 2011 at 12:31

2 Answers 2


After a little googling,

I got to this url: http://www.x.org/wiki/radeonBuildHowTo#Removing_AMD.2BAC8-ATI_catalyst.2BAC8-fglrx_driver_.28closed_source.29

Which didn't work but made me google the new error and found: https://bugs.launchpad.net/ubuntu/+source/apt/+bug/859188

There is a filed bug about it and the workaround is:

apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-glx:i386



The solution I followed was similar to that listed above, but had a couple extra steps. I did them, not knowing if the simpler one-liner would have been enough:


  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – nanofarad
    Aug 17, 2012 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .