When trying to drag a window the whole screen becomes laggy and some windows when dragged do not even appear until I release the mouse. They do appear where the window was suppose to end up after the drag but the dragging animation that happens while dragging is not seen.

I am using a NVIDIA 9500 GT 1GB with the proprietary drivers, an Intel Core 2 Duo 8500 and 4GB RAM just to make sure that this is not the problem. In 11.04 it worked correctly when dragging.

  • Experiencing this too with similar hardware. – Evan Oct 25 '11 at 3:15
  • This sounds like a bug. I've experienced something similar today, but never before. I am using a Radeon HD5850, though. – Jo-Erlend Schinstad Oct 25 '11 at 3:19

Install CompizConfig Settings Manager:

sudo apt-get install compizconfig-settings-manager

And in Composite, disable Detect Refresh Rate and slide the Refresh Rate up to more than 70.

Under Mouse Polling Position, change Mouse Poll Interval to 1.

Disabling Plugin Grid also might help, but that disables window snapping!!


  • Before accepting the answer (Which it worked for almost all windows), the last windows that move laggy are the ones used by Wine. Any thoughts about this ones. – Luis Alvarado Oct 25 '11 at 7:24
  • Notepad seems to work fine on my computer... – Evan Oct 25 '11 at 7:59
  • I tried a game. Am starting to think that the combination of Compiz activated for Unity + Wine running an OpenGL game makes the screen loose several FPS quickly. – Luis Alvarado Oct 25 '11 at 15:27
  • In General Options, Enable Unredirect Fullscreen Windows. In Workarounds, enable Legacy Fullscreen Support, this will make fullscreen windows in wine run faster. – Evan Oct 25 '11 at 20:33
  • For me this doesn't work. GTX 560 Ti on 11.10. – Laryllan Dec 25 '11 at 23:39

I had the same problem .. but the proposed fix didn't work.

What worked was to change the driver. I just typed "Additional Drivers" in dash. In the Additional Drivers window there was two proprietary drivers listed for my Nvidia card.

One was marked as "version current" and the other was marked as "post-release updates".

I changed it from "version current" to "post-release updates" and everything works fine now.


Solved the problem by installing the newer NVIDIA drivers 295+ from alternative repository.

I should, mention the the above tricks did not worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.