10

Has anyone had any success installing Ubuntu 14.04, 15.10, or any variety on the new Dell Precision 5510?

I have been trying for 3 days with very little success.

Issues I'm Facing

  1. The Intel 8260 wireless network card is not recognized.

    • Fixed in by installing 14.04 and updating to kernel 4.2, which causes the thunderbolt 3 Ethernet dongle to not work.
  2. Can't hibernate or shut down.

    • Tried Many things including:
      • +acpi=off. Works for shutdown, but won't hibernate.
      • I can't remember what else I've tried, but they were numerous.
  3. When installing Ubuntu 15.10:

    • +First: get Missing Parameter in configuration file. Keyword Path *fixed: tab -> live.
    • I get a bunch of error messages about nouveau then the system hangs.

System Information

  • Precision 5510 with a core i5, and the touch screen 4k display.
12

How to Install Ubuntu 16.04 LTS on the Dell Precision 5510

[edit: Aside from the "Allow Linux to see your storage device" step, on newer install media, this guide is no longer necessary. Just install normally, everything works.]

I was able to get Ubuntu 16.04 LTS installed over the last few days. These are my notes from the installation. Multi-monitor connections via HDMI work. The thunderbolt 3 port also works for Ethernet and Display Port. Please feel feel to revise this, and read carefully, as there are almost certainly some errors. I'm not a Linux expert by any measure.

Disable nouveau in order to boot from the Linux live disk

Do this at grub before booting from Ubuntu install media to avoid crashes due misbehaving video card drivers.

Symptoms are random freezes and infinite errors, something like the following: nouveau PFIFO SCHED_ERROR. Fix by pressing 'e' on grub menu during boot and add "nouveau.modeset=0" to the end of the line starting with "linux". Now boot the live disk by pressing F10.

Allow Linux to see your storage device

When booting, press F2 or CTRL+p to access the UEFI configuration menu. Navigate to SATA Operation on the left, and set it on the right to either AHCI if you have a hard drive, or Disabled if you have only the NVMe drive. The reason that the setting SATA Operation > RAID 0 hides the NVMe drive from Linux is that it turns on a proprietary RAID + AHCI driver, stored in firmware, called Intel RST. Linux has a difficult time communicating with the Intel RST driver without a lot of tinkering.

Once you've booted in, and with no external monitor connected, install normally. The following should be done only after you've rebooted into your newly installed system.

Install kernel 4.6 for Ubuntu

On newer install media this step isn't necessary. Run uname -a to see what kernel is running on your Ubuntu live cd. If it's version 4.6 or later, skip this step.

mkdir -p ~/Downloads/Precision_5510_install/kernel
cd ~/Downloads/Precision_5510_install/kernel
BASE_URL="http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6.2-yakkety"
wget "$BASE_URL"/CHECKSUMS
wget "$BASE_URL"/CHECKSUMS.gpg                                           
wget "$BASE_URL"/linux-headers-4.6.2-040602_4.6.2-040602.201606100516_all.deb
wget "$BASE_URL"/linux-headers-4.6.2-040602-generic_4.6.2-040602.201606100516_amd64.deb
wget "$BASE_URL"/linux-image-4.6.2-040602-generic_4.6.2-040602.201606100516_amd64.deb
gpg --keyserver keyserver.ubuntu.com --recv 17C622B0 # Import the gpg keys from Ubuntu's mainline kernel team.
gpg --verify CHEKSUMS.gpg CHECKSUMS # Verify that the list of checksums is from Ubuntu.
sha256sum -c CHECKSUMS | grep 'OK' # Check the integrity of the downloaded files.
sudo dpkg -i *.deb

You can find the gpg keys to verify the files haven't been tampered with here.

Enable hibernation

First test to see if hibernation works:

sudo pm-hibernate

If you're able to resume, create a file to allow hibernation from the GUI.

cat <<EOF | sudo tee /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes
EOF

Install Dell drivers from the Ubuntu Driver Support Pack

This step can be problematic, since you're installing .debs intended for an older version of Ubuntu. There is probably a better solution for this, but I haven't figured it out yet.

Starting the laptop with a monitor plugged in via HDMI caused my machine to crash until I did this. It may require some troubleshooting on your end.

cd ../
wget http://downloads.dell.com/FOLDER01797540M/1/xps13_ult_x03.fish.tar.gz
tar xf xps13_ult_x03.fish.tar.gz
cd debs
sudo apt-get install libxdo3 xdotool
sudo dpkg -if workaround-screen-lock-malfunction_1_all.deb

ALSA defaults to sending sound to HDMI even if there's nothing plugged in. Fix it with this:

echo "options snd-hda-intel model=dell-headset-multi,dell-headset-multi" >> /etc/modprobe.d/alsa-base.conf

Set up Nvidia Optimus

First install bumblebee

sudo apt-get install bumblebee bumblebee-nvidia primus

Next, remove any exising nvidia packages and install newer ones.

sudo apt-get purge nvida-*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-prime
sudo service lightdm restart

Add an indicator so you can tell whether Intel or Nvidia is being used.

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install prime-indicator
nohup prime-indicator &

Increase the text size on TTY consoles (for 4k screens)

On the 4k screen variety of this laptop, the font size is nearly unreadable when switching to a TTY ( for example, when pressing CTRL+ALT+F1 from Unity ). You can change it like so:

  • sudo dpkg-reconfigure console-setup
  • Choose UTF-8
  • Choose the default Combined - Latin, ... option ("Latin" includes the English alphabet)
  • Select the terminus font
  • Select 16x32

Hope it helps!

| improve this answer | |
  • Thanks for the instructions! Are these for the Dell Precision 15 5510? Do they apply to other systems (e.g. Dell XPS 15 9550) as well? What kind of power usage do you get on battery? – tisch May 3 '16 at 11:02
  • Great Notes. I will be trying this very soon, as a windows dual boot + Firmware update, issue with my laptop caused me to start over. – Steve Rumancik May 9 '16 at 15:21
  • @tisch This was tested on my precision 5510, but should also work for the XPS 15 9550. Battery life varies from 3 1/2 hours with heavy usage to 6 hours with the screen brightness turned all the way down. (I have the 86wh battery.) – justsomeguy May 9 '16 at 21:34
  • @justsomeguy hi - I am having graphicsc issues with my dell precission 5510. Particularily i can not use the nvidia card as it causes tearing in the graphics (e.g. scrolling and videos etc). I was wondering if you had also experienced that and/or you found a solution. I documented my issues here: ubuntuforums.org/… – pandaadb Jun 12 '16 at 12:34
  • You can add the public keys for kernel PPA like this: gpg --keyserver keyserver.ubuntu.com --recv 17C622B0 – Andrzej Pronobis Jun 26 '16 at 0:40
4

On my side I am now using Ubuntu 16.04 LTS (daily build image) which brings kernel 4.4 and it works pretty smoothly out of the box !

http://cdimage.ubuntu.com/daily-live/current/

EDIT : actually I am currently struggling with external monitors. I have been trying both nvidia and i915 drivers and I have to hot-plug my screen after login in to my session otherwise I get a freeze at the login screen. I also get 1 out 2 times a freeze when hotplugging my monitor once in the session.

dmesg reports :

[drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]] *ERROR* CPU pipe A FIFO underrun

| improve this answer | |
  • 1
    I have recently installed this and it works relatively smoothly with the official 16.04. Only issues I see is that no matter what drivers for NVIDIA I choose, I can not get rid of tearing. Disabling NVIDIA in prime makes the graphics useable though (for work + videos). Intel only drivers with external screens attached sometimes hard-crashes the system when it is locked. I have no idea why or how to fix it :/ Still looking for solutions – pandaadb Jun 13 '16 at 13:42
0

I haven't tried Ubuntu yet, but I was able to get Arch working on it. To do so, I got help from an Ubuntu post on installing Ubuntu on an XPS 15 9550. The Precision 5510 is basically the same computer with slight differences like which graphics card and processor it uses.

See this link for help, including getting past the nouveau crashes (those happened to me in Arch as well): http://ubuntuforums.org/showthread.php?t=2301071

I'm pretty certain you'll want to use the latest Ubuntu version and not the LTS releases since these computers are brand new and support for some of the devices has only been added to the more recent kernel versions.

| improve this answer | |
  • I stumbled upon this forum when I was trying to get Ubuntu Installed on the computer, it was a big help. Still can't get The thunderbolt jack to work. – Steve Rumancik Jan 13 '16 at 13:44
0

Steve,

I have been testing different versions of Ubuntu for use on one of the latest Dell Precision 5510's (i7, with Skylake) I ran into issues outside the scope of the problem described at first, but was able to get past them. Later, I ran into very similar problems as your describing, and following a post decided to try Ubuntu Gnome. I had success with the Ubuntu Gnome 15.04 found here, and then applying all updates. The resolution was changeable all hardware seemed to be working, but one issue remained. I was unable to shut down the laptop from the desktop power menu. It would get hung and unusable whenever I tried to restart or shutdown, so I had to use the power button. I found a post where someone suggested installing the following:

sudo apt-get update && sudo apt-get install laptop-mode-tools

They also said they had success with upgrading to 15.10 afterward, but it didn't work out so well on my model, here are the issues I experienced after upgrading to 15.10.

  • Required adding "nomodeset" to kernel parameters in order to even see a Graphical greeter, would just hang on a gray screen.
  • Required to manually unplug, then replug USB mouse in order to have it recognized.
  • The resolution was locked at 4k and the display settings had no other options available for selection.

Hope this helps!

| improve this answer | |
  • Actually, I've been able to use it a little more and it's not as stable as I thought. One of the issues, I noticed was the wireless card, and found the fix in another askubuntu post here: askubuntu.com/questions/697279/… – itnet7 Jan 25 '16 at 22:47
  • I ran into so many troubles with this laptop, and have struggled with it too much and I didn't have time to continue to fix each new issue with the laptop. I am sad to say that for the first time in 8 years, my bag contains a Windows pc... Two factors finally forced this decision, One I am now needing to support Tableau, and need the desktop client (No big deal if I could have gotten VM to work well) and lastly the Wireless Card kept going out (thank you for the link) on me when I was in meetings. I now have a Virtual machine that is Ubuntu and I still hold out hope that 16.04 will help... – Steve Rumancik Jan 28 '16 at 12:19
  • Proud to say I have 16.04 beta 2 running on this laptop, Easy install only challenge is the thunderbolt hot plug ability. Hoping real release will fix this. But I am back on Ubuntu so I am happy again. – Steve Rumancik Apr 20 '16 at 1:38
  • Thanks for letting us know Steve, Will check out upgrading soon. – itnet7 May 2 '16 at 17:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.