0
  • Ubuntu 15.10
  • kernel 4.2.0-22-generic
  • bluez 5.35-0ubuntu2
  • Dell m3800, Broadcom BCM4352 wifi/bt module

I followed other instructions on this help site for getting a proper driver installed for my BCM4352 wifi/bt card, and wireless works fine and BT worked okay to pair an Apple magic trackpad.

When I try to pair my Jaybird X2 headset, it pairs, but won't "connect" and I'm unsure what else to try. I contacted Jaybird support and they showed me how to factory reset the headset to wipe all pairing, but adding it back on my system it pairs but no audio controls are present.

When I use the bluetooth manager to set up the device I get a message saying "Device paired successfully, but failed to connect". I have it marked as 'trusted' (whatever that means) but it hasn't helped.

When I go through system settings for Bluetooth I see the device, it shows it's paired, but the connection button is ghosted:

enter image description here

Since my trackpad works just fine, I'm not sure this is a BT driver issue, but perhaps an issue with my headset, though the headset is paired with and works fine with the Windows 10 installation on this laptop, and also on my Nexus 6 and a workstation at home which is also dual-booted as Linux/Win10. Jaybird tells me the headset can pair with up to 10 devices so it's not a limitation of pairing too many times.

EDIT: Jaybird says pairing must use passcode 0000 yet there's on option for that in Ubuntu 15.10 ... I only get options for pairing using a random PIN or not to connect at all. I'm curious if this is the root of the problem, and how I should get the '0000' option back? (it's been there in previous Ubuntu versions)

0

Turns out to be a bug in pulseaudio, not bluez.

The accepted answer on this post solved the problem for me: PulseAudio can not load bluetooth module 15.10/16.04/16.10

It feels like a bit of a hack workaround, but it works.

  • Does it still work under 16.04 (if you have upgraded) I have the same problem and the solution does not work.. Only for other bluetooth devices. – Joakim Koed May 31 '16 at 10:50
  • No, upgrading to 16.04 also broke my system, and following these instructions no longer works. Fedora 23 works out of the box though, no fusing with extra firmware etc so I'll likely move to that in the next week. I've grown frustrated at Ubuntu's failings like this... my built in synaptics trackpad also stopped working properly and my screen flickers after the upgrade. Dell says it could be several months before they'll officially support 16.04LTS. – iandouglas Jun 1 '16 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.