6

In my new ubuntu 11.10 install the Tomboy notes synchronizes just some of my notes notes and then fails. The details only shows the updated notes. When I look at the .config/tomboy/tomboy.log I see the error:

10/24/2011 11:12:29 PM [ERROR]: Synchronization failed with the following exception: A note with this title already exists: New Note Template
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String xml_content, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.NoteManager.CreateNoteFromTemplate (System.String title, Tomboy.Note template_note, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.NoteManager.CreateWithGuid (System.String title, System.String guid) [0x00000] in <filename unknown>:0 
  at Tomboy.Sync.SyncManager+<CreateNoteInMainThread>c__AnonStorey11.<>m__3F () [0x00000] in <filename unknown>:0 
  at Tomboy.GuiUtils+<GtkInvokeAndWait>c__AnonStoreyC.<>m__2F (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0 

I have tryed changing the URL on the sync preferences to https://edge.one.ubuntu.com/notes/ as sugested in question 66753 but it did not work.

9

Not sure if I am supposed to answer my own question but I have managed to solve the problem.

Since the error on the log mentioned a note named "New Note Template" I created a note with that name through the ubuntu one web site and then tried to sync again. This time tomboy detected the conflict and offered some options to solve it. I chose to rename the local note and then it synced all my notes correctly!

| improve this answer | |
1

Thanks 'lpanebr' for the reference to change server address in Tomboy Preferences to:

https://edge.one.ubuntu.com/notes/ note the addition 'edge' to the address

Sync proceeded OK.

| improve this answer | |
1

I opened the Tomboy Preferences, and on the first tab (Editing), clicked "New Note Template". I then renamed the Template title to "Title" instead of "New Note Template". Then closed this template note, and synchronization worked.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.