Help how do I open this. the README file says


From the graphical desktop, click on:
 "Access Your Private Data"


From the command line, run:

How do I run this so that I can get my data?

3 Answers 3


You are trying to access data from an encrypted directory. To do this, log in as the user owning the data in question (eg sally for /home/sally). If the home directory itself is encrypted, logging in will automatically decrypt the data. If it is a Private directory, there should be a launcher in that folder to click (which may again prompt you for the user password).

If the "Access Your Private Data" launcher fails for some reason, use this command and follow instructions:


If, for some reason, you have the data in question independent of the system it was used in, you will need the private key that Ubuntu's encryption wizard asked you to save on installation.

If you have neither the password for user with that encrypted directory, nor the private key, I'm afraid there is no way to recover the data.

  • 2
    What if the owner of the home directory does not exist? I installed over the previous installation with a different user name leaving only the old home directory.
    – zorkerz
    Feb 8, 2013 at 23:44
  • seems to require root's password and not the users? Nov 26, 2013 at 22:07
  • Does it need reboot? I executed ecryptfs-mount-private but no difference. It came back to normal operation after reboot! I don't know which one caused this.
    – SuB
    Sep 1, 2014 at 14:36
  • @Jjed : My situation is different. Please be kind enough to go through this: askubuntu.com/questions/681019/…
    – kiran bbnl
    Oct 7, 2015 at 19:18

Try logging into as the "USER" whose directory you are trying to access. I faced similar problem when accessing information of that of "user" logging in as a "root" user.


This bug happens quite frequently for me on Mint 19.1 Cinnamon for some reason, and without any obvious cause (except time). I find that running the command in an already open terminal does not work. However this works for me:

  1. Open a new terminal windows (don't use an old one)
  2. Run ecryptfs-mount-private without sudo. If it worked, there is no output in the console (no error, no asking for password).
  3. Refresh the files in file browser (nemo) to ensure it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .