0

I have a problem with my Ubuntu 12.04. I installed SVN on ubuntu. it worked fine (I never shut down, as it was server). Last night Ubuntu crashed, and upon restarting, I got the following error:

Error: No such partition

Running ls command give me (hd0)

I ran commands mentioned in https://askubuntu.com/a/495993/489369, but it still giving me the same issue.

How can i fix it? Please, point me to the right direction. Thanks in advance.

  • Boot into a LiveCD and install and try Boot-repair-Disk. You will get loads of details abouts it If you google it :P – user441517 Jan 5 '16 at 9:42
0

This error is caused when the GRUB is damaged.

So my solution is:

Update the GRUB.

  1. Have an installation disc of Ubuntu 12.04.
  2. There boot from with this disc.
  3. Then choose Rescue broken system.

That's all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.