Upon creating a brand spankin new project in Monodevelop 5.10 on Ubuntu 14.04 I get the follow in error

Project does not support framework '.NETFramework,Version=v4.5'

I have read a couple posts saying I simply just have to change the target framework in preferences under load/save I cannot find the option to change this, I have been through the menu quite a few times now with several new test projects. I found another couple solutions that say I can just change the solution file (something I have had to do on windows before) and this only sorta worked since non of the packages would load correctly and were throwing errors.

Things I have tried. https://stackoverflow.com/questions/9623964/new-default-vb-net-project-immediately-gives-an-error





Anyone got an answer? I would be delighted. Sorry its been a long night.


I had the same issue. I changed the 4.5 in the TargetFramework in the *.vbproj file to 4.0 via a text editor.

You can get to the .vbproj file through terminal, just open in a text editor and make the change. After you reload your solution it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.