9

I am using a dell latitude E5440 with Ubuntu 14.04 LTS. The WiFi suddenly stopped working today.

I tried pinging a few ip addresses and ping works fine, but pinging any URL does not.

Seems to be a DNS issue, but I didn't touch anything like that. What is wrong here?

14
  • You tried rebooting? Jan 5, 2016 at 2:47
  • Yep..the laptop..the router..enable/disable networking & wifi
    – nikel
    Jan 5, 2016 at 2:50
  • Try sudo dhclient -r then sudo dhclient Jan 5, 2016 at 2:52
  • I believe the second command was sudo dhclient (without a -) , release worked fine..but the second command does not return
    – nikel
    Jan 5, 2016 at 3:09
  • That - near the second one isn't part of the command. It's the separator for my name. Jan 5, 2016 at 3:10

2 Answers 2

15

Thanks to zacharee1, had to release and renew ip addresses. Also had to flush ip addresses :

sudo ip link set wlan0 down 
sudo ip addr flush wlan0 
sudo ip link set wlan0 up
sudo dhclient -r
sudo dhclient
3
  • @zacharee1 : I am pretty much ending up doing this once in every 1 or 2 days. Any idea why it keeps happening again and again?
    – nikel
    Jan 20, 2016 at 16:34
  • @zacharee1, I've been having a similar issue that this solution works for. As nikel experienced, the problem resurfaces every few days. How can I effect a permanent fix? I'm running 16.04.1 (xenial) Nov 4, 2016 at 15:53
  • As expected, failed with my wifi connecion with authentication certificate. Nov 23, 2017 at 9:51
1

I was facing exactly the same issue, it's fairly obvious that's something related with the DNS and I finally solved adding the DNS servers of this way:

sudo vim /etc/resolvconf/resolv.conf.d/tail

write the DNS servers in the file:

nameserver 8.8.8.8
nameserver 8.8.4.4

Restart the NetworkManager service:

sudo systemctl restart network-manager.service

That's it! Try this...Thank me later!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .