I'm using Ubuntu Gnome 15.10 with Linux 4.2.0-22-generic #27-Ubuntu SMP Thu Dec 17 22:57:08 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux.

I cannot enable the Bluetooth device built-in my laptop Toshiba Satellite C845. It has a Toshiba ACPI Bluetooth device driver. There is a device hci0 which I get timeout after command:

$ hcitool scan
Scanning ...
Inquiry failed: Connection timed out

However, I get a MAC address:

$ hcitool dev
    hci0    44:6D:57:05:6A:81

I have this output from command:

$ dmesg | grep -i bluet
[    1.590914] usb 3-1.3: Product: RT Bluetooth Radio
[    8.168356] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[   10.178847] Bluetooth: Core ver 2.20
[   10.178864] Bluetooth: HCI device and connection manager initialized
[   10.178868] Bluetooth: HCI socket layer initialized
[   10.178871] Bluetooth: L2CAP socket layer initialized
[   10.178876] Bluetooth: SCO socket layer initialized
[   10.498021] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=0e3d lmp_ver=06 lmp_subver=a5b1
[   10.498026] Bluetooth: rtl: assuming no firmware upload needed.
[   17.512991] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   17.512994] Bluetooth: BNEP filters: protocol multicast
[   17.512998] Bluetooth: BNEP socket layer initialized
[   19.514692] Bluetooth: hci0 command 0x0c56 tx timeout
[   27.481207] Bluetooth: RFCOMM TTY layer initialized
[   27.481216] Bluetooth: RFCOMM socket layer initialized
[   27.481223] Bluetooth: RFCOMM ver 1.11
[ 4118.722944] usb 3-1.3: Product: RT Bluetooth Radio
[ 4119.317636] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 4119.317646] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[ 4128.043128] Bluetooth: hci0 command 0x200c tx timeout
[ 4235.120749] Bluetooth: hci0 command 0x0401 tx timeout
[ 4365.282581] Bluetooth: hci0 command 0x0c1a tx timeout
[ 5014.738593] usb 3-1.3: Product: RT Bluetooth Radio
[ 5015.335446] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=1200
[ 5015.335455] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723a_fw.bin
[ 5023.586749] Bluetooth: hci0 command 0x200c tx timeout
[ 5281.283140] Bluetooth: hci0 command 0x0c1a tx timeout
[ 5294.988048] Bluetooth: hci0 command 0x0401 tx timeout
[ 9177.900062] Bluetooth: hci0 command 0x0401 tx timeout
[10898.765848] Bluetooth: hci0 command 0x0c20 tx timeout
[10920.331256] Bluetooth: hci0 urb ffff8801d0bda180 failed to resubmit (113)
[10920.331629] Bluetooth: hci0 urb ffff8801d0bda0c0 failed to resubmit (113)

I understand there is a physical device which doesn't get a driver to operate. When I see the output of lsusb, then I get:

Bus 003 Device 002: ID 0930:021d Toshiba Corp.
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          224 Wireless
  bDeviceSubClass         1 Radio Frequency
  bDeviceProtocol         1 Bluetooth
  bMaxPacketSize0        64
  idVendor           0x0930 Toshiba Corp.
  idProduct          0x021d 
  bcdDevice            2.00
  iManufacturer           1 Realtek
  iProduct                2 RT Bluetooth Radio
  iSerial                 3 00e04c000001
  bNumConfigurations      1

... What is missing that I cannot load a driver/module to get enabled this bluetooth device? Is not Toshiba an Ubuntu-friendly manufacturer?

Any ideas, please?

  • I'm not happy with the Tumbleweed achievment that I earned with this question... I really want to find out how to solve it, and so I'm asking for the experts around if they can help me.
    – LobaLuna
    Feb 9, 2016 at 18:12
  • did you solve this issue? If not, I can offer a 500 rep bounty as I need a solution too. If yes, please tell me the solution. Dec 14, 2016 at 11:44
  • No, I haven't. Maybe you can open the bounty to everyone else. And I'd love to see the solution.
    – LobaLuna
    Dec 17, 2016 at 2:55
  • Have you tried running a more recent version of Ubuntu? 16.04 or 16.10? There is a chance their more recent kernels support your hardware better. You do not have to install a new version to try it: simply run Ubuntu from a bootable USB key (choose to "try it" and no "install it") and see if Bluetooth works. Dec 20, 2016 at 12:30
  • 1
    @AdrienBeau The problem is not with the newer/older OS. The support has been there for long time, it simply works for some OS, and simply doesn't for some. Issue is somewhere in the messy stuff distros do with the kernel/user space stuff. There has to be a solution for this though. Have a look at this github.com/lwfinger/rtlwifi_new/issues/187 Dec 22, 2016 at 6:34

3 Answers 3


Similar problems were reported last year here (kernel 4.1.1: Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_fw.bin) on Ubuntu forums.

Summary of steps to solve it there (which you probably shouldn't use!):

sudo dpkg -i  linux-firmware_1.145_all.deb
sudo updatedb
rfkill list all; hciconfig -a

Updated steps for your Ubuntu 15.10 on the other hand would be:

sudo apt update
sudo apt install linux_firmware
rfkill list all; hciconfig -a

This is based on instructions for 15.10 found here (https://www.howtoinstall.co/en/ubuntu/wily/linux-firmware)

Additional information that may prove helpful can be found here (Bluetooth not detecting any devices) where Pilot6 wrote an answer for an rtl8723au-bt driver.

As far as Toshiba's suitability for Linux... historically it has been very good however recently I've read comments some new machines are Windows only. In this case however it's more a reflection of RealTek / Broadcom hardware installed inside which Dell's could also have. Either manufacturer could also have Intel hardware WiFi / Bluetooth as well though.

FTR I have a Dell Laptop with Intel inside and haven't had any real bluetooth problems to date (fingers crossed). Hopefully your problems get solved soon!

  • I upgraded recently to 16.04, hoping for a solution already set in kernel, but I still have no luck. Thanks, anyway. My driver is rtl8723a, BTW, and I suppose there are minor but crucial differences with rtl8723au because your suggestion didn't work on 16.04.
    – LobaLuna
    Dec 21, 2016 at 23:09
  • I confirm that installing an up to date linux-firmware is required, along the drivers. For ubuntu 14.04 I installed this: packages.ubuntu.com/xenial-updates/linux-firmware ALSO: I'm running kernel 4.4.0-131
    – develCuy
    Aug 24, 2018 at 15:45

A local AskUbuntu user, Pilot6, provided a PPA (ppa:hanipouspilot/rtlwifi) containing the required drivers to ensure that the RTL8723 chipset works with your machine.

Essentially, you need to add this PPA to your system:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi && sudo apt update

Next, install the appropriate DKMS modules and drivers to your system:

sudo apt install rtlwifi-new-dkms linux-firmware rtl8723au-bt-dkms

These two commands (combined) will install the required drivers to your system and kernel. Additionally, this will work after any kernel update, due to the nature of DKMS.

Furthermore, you are also installing linux-firmware, which allows for some (better) firmware support for similarly quirky devices.

If you would rather compile from source, you can see this answer, which also includes (further) PPA information. Alternatively, if you want DKMS support, check here.


Try this with in terminal :

sudo apt-get install bluez

More steps are explained here :


So as explained there above this link next steps would be :

sudo /etc/inet.d/networking restart


sudo /etc/inet.d/bluetooth start


  • I already have bluez installed, but still cannot connect. I follwed the tutorial you suggest. Thanks.
    – LobaLuna
    Dec 21, 2016 at 23:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .