0

I recently purchased a new (2015) Toshiba Satellite S50-C, wiped Windows 10, and have been attempting to install Ubuntu for several days.

Details on the machine: Intel Core i7-6500U Processor (4M Cache, 2.50 GHz) with Intel Turbo Boost Technology 2.0 (x64-based processor) 16 GB DDR3L 1600MHz = 8GB + 8GB 1.0TB (5400rpm); Hybrid 8G Serial ATA hard disk drive 256GB M.2 Solid State Drive (SSD); 4GB DDR3 NVIDIA GeForce FTX 950M with NVIDIA Optimus Technology; 15.6" FHD TruBrite display (1920x1080)

I am attempting to install Ubuntu on the 256 GB SSD.

After failing to get 14.04 to install (usually some problem with failing to boot or freezing), I decided to go with 15.10 since my hardware is so new. I have completed a 15.10 install via thumb drive, in CSM boot mode (not UEFI), and with the Intel Turbo Boost Technology disabled. I then re-enabled the Turbo boost after install.

Now, I am unable to proceed past the login screen. It goes black, flashes a purple screen, and then returns to the login screen. Guest login also does not work.

CTRL + ALT + F1 (or F2, F3) do not work to get me into a terminal from the login screen. However if I enter the GRUB edit screen (typing 'e') in startup when GRUB is displayed, I can access a terminal by adding '3' at the end of the linux line (runlevel 3). Also, at the recommendation of add'l posts, I have added the following to the same line in GRUB:

replace 'quiet splash' with 'nomodeset'

i915.modeset=0 i915.i915_enable_rc6=1 nouveau.blacklist=1

I am not sure if any of the above is necessary.... I originally added 'nomodeset' because I was booting into a black screen. This seems to have solved that issue, but has created the login loop issue.

I have a feeling this is related to the NVIDIA driver. In a previous successful login, the graphics were incredibly slow, but I was able to change the driver (via the 'additional drivers' GUI) from Nouveau to NVIDIA proprietary. Running dkms status in my runlevel 3 terminal gives:

bbswitch, 0.7, 4.2.0-22-generic, x86_64: installed
nvidia-352, 352.63, 4.2.0-22-generic, x86_64: installed

Also, I have read that permissions with .Xauthority can be a common problem, however, when I run ls -lah, I have:

-rw------- 1 pwright pwright 54 Jan 4 12:37 .Xauthority

Any advice would be greatly appreciated!!

  • Update: I can now get a terminal from the login screen, with CTRL + ALT + FN + F1, and I am almost certain this problem has something to do with the driver. I have done another install of Ubuntu 15.10, this time in UEFI mode. After install, I have a functioning system, but the computer will randomly freeze after a few minutes. I installed the specific model NVIDIA driver for my hardware (352.63) following this procedure. Now I am back to the login loop problem (unable to log in). Any ideas???? – PJW Jan 5 '16 at 6:44
0

Install the drivers from the GPU Drivers PPA, which contains the latest official NVIDIA drivers.
This often leads to properly working graphics, especially on very new NVIDIA GEFORCE cards.

First uninstall the NVIDIA software you already have had installed before.

Highlight the Ubuntu entry in the GRUB boot menu and press the E key.
Add nouveau.modeset=0 to the end of the linux line - press F10 to boot.

On login screen press Ctrl+Alt+F1 - enter your user name and password - then execute :

sudo apt-get purge nvidia*  
sudo reboot  

Install the latest stable NVIDIA drivers and Optimus support for GTX 950M.

Highlight the Ubuntu entry in the GRUB boot menu and press the E key.
Add nouveau.modeset=0 to the end of the linux line - press F10 to boot.

On login screen press Ctrl+Alt+F1 - enter your user name and password - then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358 nvidia-prime
sudo reboot
  • I performed these steps (....the purge indicated "0 removed"). Although I can now successfully login, I land on the purple Ubuntu background, but with no desktop (no menus, icons, etc...). A "system program problem detected" message box appears. I can right-click and pull up a terminal and navigate the file system. For the the line in the grub file GRUB_CMDLINE_LINUX_DEFAULT= , I have tried: "nouveau.modeset=0", "nomodeset nouveau.blacklist=1 nouveau.modeset=0", "i915.preliminary_hw_support=1 nouveau.modeset=0". Should I possibly try nvidia-355? Thank you! I feel like I am getting closer... – PJW Jan 8 '16 at 21:46
  • Any further advice much appreciated.... unfortunately still stuck with a machine w/no operating desktop. – PJW Jan 9 '16 at 4:29
  • @PJW : Just give it a try ... remove all these parameters from the GRUB file - purge nvidia* - after the reboot install nvidia-355 using the same method as described in the answer ... good luck ! :) – cl-netbox Jan 9 '16 at 9:17
  • Success!! I did a clean install of Ubuntu 15.10, electing NOT to install updates or 3rd party software (perhaps other drivers were installing with this previously?). Booted into a screen with an error message about graphics. Dropped into terminal. Executed all of your instructions as posted above. Except: I did NOT add "nouveau.modeset=0" to the linux line in grub. Just left with default "quiet splash". nvidia-358 appears to be working great. Likely, I had some other nvidia drivers, or other config files in my system folders left over from other attempts that may have been interfering. Thanks! – PJW Jan 10 '16 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.