1

I am using Xubuntu on Lenovo 3000 G430 Laptop. For touchpad to work everytime after startup:

  1. I have to press Fn+F8 (This will lock touchpad)
  2. Now, light on my touchpad glows,
  3. And then I have to press Fn+F8 (This will unlock touchpad)
  4. And then it starts to work.

I have tried:

xinput set-prop 14 "Device Enabled" 1

( 14 being the device id of touchpad. No luck )

I have tried (without success):

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps  

xinput --list

⎡ Virtual core pointer                           id=2    [master pointer  (3)]  
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]  
⎜   ↳ PixArt USB Optical Mouse                  id=10   [slave  pointer  (2)]  
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]  
⎣ Virtual core keyboard                         id=3     [master keyboard (2)]  
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]  
    ↳ Power Button                              id=6    [slave  keyboard (3)]  
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]  
    ↳ Power Button                              id=8    [slave  keyboard (3)]  
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]  
    ↳ Lenovo EasyCamera                         id=11   [slave  keyboard (3)]  
    ↳ Ideapad extra buttons                     id=12   [slave  keyboard (3)]  
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]  

How to make touchpad work directly after startup ? ( I want to skip pressing Fn+F8 twice everytime. )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.