2

When I try to open Qt Creator, it loads fine but after a couple of seconds, the application window becomes unresponsive and turns gray. I can move the window around, but cannot interact with it. It remains like this indefinitely.

The same thing happens if I try to open a Qt project file with Qt Creator.

And if I try to close the window, I get a dialog box that reads:

This Window is not responding
Do you want to force the application to exit, or wait for it to respond?

This happened all of a sudden, while I was working on a Qt Creator project. I don't remember making any change to the Qt Creator installation either.

Among a few things that I have already tried are:

  1. Restart my machine
  2. Uninstall and reinstall Qt Creator (using Ubuntu Software Centre)

What else should I try to solve this problem?

  • Are you using the ubuntu sdk? – Goddard Jan 4 '16 at 18:57
  • I don't know what that is, so not as far as I am aware... – Karnivaurus Jan 4 '16 at 19:19
  • Try starting it in a terminal like qtcreator – Goddard Jan 4 '16 at 19:21
  • If I run it from a terminal, I get the same behaviour. – Karnivaurus Jan 4 '16 at 19:26
  • Did you get errors? If so what where they? – Goddard Jan 4 '16 at 19:57
1

I eventually managed to solve this by removing the directory QtProject and the file QtProject.conf from the directory ~/.config. After doing this and restarting QtCreator, it seems to now run as expected. However, I don't understand the real reason behind why this worked.

| improve this answer | |
0

You only need to remove the file ./config/QtProject/QtCreator.ini.lock It seems that QtCreator marks a file as 'locked' by writng this file. If it dies while this is still present and fails to delete it, QtCreator believes the lock is still held when it tries to restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.