0

I have an 1.5tb external hdd. Yesterday morning it worked well. The system accidentally freezed, and i restarted the system and i cant mount the partition. I removed the hdd from the cage, and used ddrescue to copy the partition image into a file.. The copy was successfull without any errors, so the hardware seems ok. But i cant mount, the e2fsck freezes as well. If i start, eats some cpu for 1-2 seconds then stops working.

What can i do ? I've read lot of threads, but i havent found anything about this problem. If nothing will work, is there any way to rescue few directories ? It would be very very important. At christmas night my main hdd damaged, this hdd was my backup disc. I bought spare hdd thats why i started to copy files from this disc when this happened, so i dont have any backups.

  • it seem i solved the problem, i can mount the partition without journals. – ant75 Jan 4 '16 at 11:53
  • If you solved your problem, can you please write the solution as an answer and accept it, to let others know how it was solved. – Wayne_Yux Jan 4 '16 at 13:41
  • Possibly the problem was with the jorunalling fs, and fsck and the mount cannot handle the problem well. So i mounted the fs with the following mount flags: -t ext4 -o ro,noload. This worked for me well. – ant75 Jan 5 '16 at 16:46
0

Possibly the problem was with the jorunalling fs, and fsck and the mount cannot handle the problem well. So i mounted the fs with the following mount flags: -t ext4 -o ro,noload. This worked for me well.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.