0

I'm having some huge problems installing ubuntu 15.10. Here's the story:

1) I used to have 14.04 on my PC and everything was working very happily. However, yesterday, I got a window proposing me to update to 15.04; during the usual update procedure I got plenty of error messages saying many packages couldn't be properly configured. At the end the installer said the update failed and tried to reset to old configuration. But something must have gone wrong, since I couldn't restart the pc. Thus, I decided to erase and install directly the latest version.

2) To backup I used an old 13.04 live CD and everything worked.

3) Meanwhile I created a 15.10 live USB. When I tried it, it couldn't create a live desktop, freezing on a black screen after the ubuntu logo. Also selecting "install" brought to a freeze immediately after the install window appeared.

4) I read for some hardware one needs to set "nomodeset" in grub and I did it. This indeed allowed me to begin the installation procedure; however, it freezed trying to connect to WiFi.

5) I connected to WiFi using the live 15.10 and launched the install afterwards. Everything worked.

6) However, when rebooting I get again a black screen after the ubuntu logo. Setting nomodeset in grub seems to be of no help now. I also tried to add nomodeset in /etc/default/grub in recovery mode, but the file opens in read-only mode with nano, so I cannot edit it

Do you have any suggestions?

Many thanks

  • What graphics card do you have on your laptop? – aramboi Jan 4 '16 at 10:17
  • Intel HD Graphics 4400 and AMD Radeon HD 8750M. The PC is Aspire E1-572g-54206G1TMnkk – popoolmica Jan 4 '16 at 10:31
  • How did you create a 15.10 live USB? – dragon2fly Jan 4 '16 at 14:15
  • I used another pc, why? – popoolmica Jan 4 '16 at 19:13
0

Boot into recovery mode by selecting Advanced options for Ubuntu in the boot menu and then the option that has appended recovery menu to the latest kernel version string. If the Grub menu does not appear when booting, press Shift or Esc while booting.

You will be presented with several options as seen below:

Recovery menu

Choose the Enable networking option (you need a wired connection at this point). After that is finished choose the option to Drop into root shell prompt. In the shell do:

$ apt-get update && apt-get upgrade
$ reboot

If updating the software packages did not solve your issue, you can try to install the proprietary ATI drivers in recovery mode:

$ apt-get purge fglrx*
$ reboot  # only if there was something to uninstall otherwise go to the next step
$ apt-get install fglrx 
$ amdconfig --initial
$ reboot

If network is unavailable, download the driver from here http://support.amd.com/en-us/download/desktop?os=Linux+x86_64 and unarchive. Copy the folder on the laptop using the live CD and then in the recovery mode root shell do:

$ cd /path/to/driver.run
$ chmod +x amd-driver-installer-XX.XXX-x86.x86_64.run
$ ./amd-driver-installer-XX.XXX-x86.x86_64.run
$ amdconfig --initial
$ reboot

You should be able to boot into Ubuntu normally now.

NOTE: for nVidia systems use the following commands after dropping into root shell:

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:1c.4/0000:03:00.0 ==
model    : GM107M [GeForce GTX 960M]
modalias : pci:v000010DEd0000139Bsv00001028sd000006E1bc03sc02i00
vendor   : NVIDIA Corporation
driver   : xserver-xorg-video-nouveau - distro free builtin
driver   : nvidia-352-updates - distro non-free
driver   : nvidia-352 - distro non-free recommended

$ apt-get install nvidia-352  # the number must match the version you got above
$ nvidia-xconfig
$ reboot
  • Thank you very much form your answer. Unfortunately, when I try to update no packages can be downloaded, supposedly because even though I enabled network the PC is not connected yet. Is there a simple way to get a connection via command line? – popoolmica Jan 4 '16 at 13:23
  • You need a wired network connection. (updated the answer) – aramboi Jan 4 '16 at 13:47
  • It seems to be not working. When I choose enable networking I read for some instants an error on something Luke /run/resolconf/interface and then "trying to start network manager" but there is barely time to read: immediately I'm sent to the previous menu... – popoolmica Jan 4 '16 at 13:58
  • If network is not available even with a wired connection you will need to download the driver on another computer from here support.amd.com/en-us/download/desktop?os=Linux+x86_64 – aramboi Jan 4 '16 at 14:34
  • Updated the answer. Try installing the drive from AMD directly. – aramboi Jan 4 '16 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.