2

first time poster on here, on and off Linux user over the last 20 years.

Running 64bit Ubuntu 15.10, downloaded the latest VLC from the Software Center (2.2.1-3), also found out that I needed to download the ubuntu-restricted-extras for extra codecs, so I did that as well (and rebooted.)

Most of my videos are in either avi, mp4 or wmv format. The default Videos app can play them all perfectly, full sound, full video. What it can't do (and one reason I like VLC so much), is scrub through to different parts, so I'm forced to watch the entire thing if I want to see a certain part. (I use VLC on my Mac, and it works flawlessly with all of these videos.)

What VLC on Ubuntu is doing:

  • It won't even play avi or wmv files.
  • It plays mp4 files, but with no sound and no video. So basically a black screen, but I can scrub through to different parts.
  • It also will play the few .flv movies I have with sound and audio - the only format it seems to recognize right now.

What I've done:

  • Checked VLC to make sure all audio is not disabled (sound is definitely on throughout the system)
  • Downloaded and installed the ubuntu-restricted extras (it does seem to have an issue with the Microsoft Truetype fonts, as though there's something missing, but that shouldn't have anything to do with the audio/video issues.)
  • Gstreamer plugins are installed (looks like it includes support for wavpack and quicktime as well.)

  • And I have looked all around online for this problem, but I've only seen maybe 1-2 instances where it won't play audio or video, most issues are either one or the other.

Any help with this would be greatly appreciated!

Thanks,

  -Bryan
  • can you specify more about the hardware on which Ubuntu is running? – somethingorange Jan 4 '16 at 8:35
  • It's running on my older 2011 Mac Mini hardware: Intel Core i5-2415M 2.30Ghz x 4 Intel Sandybridge Mobile graphics Until I got my new Mac, I was running OS X on here with all these same videos/VLC, so the hardware is definitely capable of doing it. – Bryan Sproles Jan 4 '16 at 8:58
  • yes, so it seems...... I think it might be just an init package or something... have you tried installing older VLC releases? download.videolan.org/pub/videolan/vlc – somethingorange Jan 4 '16 at 9:05
  • Haven't tried that yet, will uninstall VLC from software center and try a slightly older version. – Bryan Sproles Jan 4 '16 at 9:17
  • I tried loading the older version, but I still have the same problem...VLC is usually so effortless to "just work". I remember it working on my last Ubuntu, which I think was around the 12.x series. – Bryan Sproles Jan 5 '16 at 4:23
0

Do you recall sending your Mac for a custom hardware installation or something of the likes?... though I don't think that's the issue here.

It seems that the integration of the two wasn't perfect. Maybe a corrupted USB stick or something similar.

Since you're mostly using common codecs, there's no need for extra packages to be installed, and maybe that's the problem.

Try uninstalling all and reinstalling using a common "as-is" setting - meaning, just run Ubuntu 15 with VLC 2.2 - no added packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.