1

I get no icons in the toolbars of Kdenlive in Ubuntu Studio 15.10. There are two of them, the usual one below the menu bar (New, Open, Save, Undo, Redo, Copy, Paste) and the Render (not a button, only the text) in an extra toolbar.

Apart from this, there are no buttons/icons in the clip monitor, only buttons with text. In all cases, I have tried changing the settings (in Kdenlive) from "Text alongside icons" to "Icons only", but to no avail.

I tried changing themes, which didn't solve the issue, and Kdenlive didn't allow me to configure the themes in Settings, resulting in the error Cannot start Colors Settings panel from KDE Control Center. Please check your system...

Have any of you experienced similar problems, and if you have, did you solve them? I'd prefer not to install Plasma 5.x or the Kubuntu Desktop, since I've read it messes up the whole OS. I'd rather stick with text buttons, than having to reinstall Linux.

I solved the issue partly, by configuring the toolbars in Settings, and changing the icons. See this picture. Now I only could get a few of the many icons to work in Kdenlive, so the chosen icons are not very conventional. Still, I feel this is better than no icons at all. Ubuntu team - pleaaaasssseeee resolve this error.

1

Ok - this is a late answer and the ones already given cover most cases. But I want to add that sometimes the impression that icons do not appear stem from kdenlive's compact and expanded modes of showing tracks. In the compact mode it does not show icons. Like that:

KDENLive's compact track view

It might be the default in your case - you're not seeing the familiar icons because it is not in "big" (expanded) mode. You just need to click the discreet icon "Bigger tracks":

enter image description here

And then, BAM! You are in expanded mode, which shows the icons:

enter image description here

Hope this helps people for whom the first two solutions did not help!

1

I had a similar problem in Ubuntu 14.04.3. When I tried to run Kdenlive as a root:

root@COMP:~# kdenlive

I got this error in console:

Error: standard icon theme "oxygen" not found!

In Synaptic Package Manager I have searched for "oxygen" and reinstalled everything installed. This solved my issue with missing Kdenlive icons.

Make sure you have installed Oxygen default icon theme.

  • 1
    Thanks, it seems the solutions to the issue vary a lot from system to system. Sometimes it's installing the Oxygen theme, in other cases Breeze. One solution involved installing kde-runtime and kde-workspace-data, but I think that only worked for Kdenlive 09.10.0. Now I have Ubuntu Studio 16.04 Beta, and by adding the Sunab repositories, and consequently updating to Kdenlive 15.12.1, the icons are all there. – theodorn Mar 4 '16 at 7:54
  • I needed the breeze icon theme as well. – To Do Mar 23 '16 at 17:57
0

I found a solution, sort of. By using the latest pre-built binary package.

https://userbase.kde.org/Kdenlive/Manual/Installation#Installing_from_pre-built_binary_packages

Quite simple, I just downloaded the latest package, opened it in the archive manager, and dragged the extracted folder with all the necessary files, as a subfolder under the kdenlive folder resulting from the installed Kdenlive of Ubuntu Studio 15.10.

The sandboxed version is the latest one, 15.12, and it has all the icons and menus in place. The only problem is, that the effect stack hides itself under the Kdenlive window, but I can bring it back or drag Kdenlive to the side to reach the effect stack. Actually, this also happens in the pre-installed 15.08 Kdenlive of Ubuntu Studio 15.10.

So Kdenlive is quite buggy in Ubuntu Studio 15.10, but better than in Linux Mint 17.3. In Mint Cinnamon 17.3, the procedure above did not work. Thought I'd share this, if any other Ubuntu users are dealing with the same thing. Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.