I'm struggling with mapping my mounted Synology NAS folders so Plex can find them. So far, I have had most success with the following thread: How do I add a network drive to Plex?

However, I get stuck half way through.

I use the following in fstab: // /media/movies cifs username=USERNAME,password=PASSWORD,iocharset=utf8,sec=ntlm 0 0

When trying sudo mount -a, I get prompted for a password and I'm not sure why: "Password for root@//"

I'm assuming it has something to do with user permissions in Synology but have been stuck for hours trying to find a solution. Would anyone be able to help, please?


  • And you're sure that the username and the password are correct? – A.B. Jan 3 '16 at 20:17

As you have probably figured out, this has very little to do with Plex. All Plex does is look at the folders presented to the local linux machine as the active Plex user, which by default is the user 'plex'.

Given you are being prompted for a password, this is likely the sticking point, or at least the first sticking point to begin addressing fault finding - (the second one will be just making sure that the files and directories have appropriate access).

Before I say anything further though, I've personally found NFS to be much more reliable and simpler to set up. Basically NFS is less CPU intensive and works better between *NIX systems anyway. If you want to go down that route, here's an example of one of my NFS lines in my fstab in case it helps: /mnt/Video nfs rw,hard,intr 0 0

Another option for you is to use the chmod command and make sure that read only is set to everyone. That way, you could omit the password altogether. So, on your NAS (and in a console) type in 'sudo chmod -Rv 764 yoursharedirectory'. I'd say that would do the trick.

I've now written a whole guide on plex permissions, which can get into quite a complex topic but I've tried to keep it as simple as possible.

Have a look at the link below and let me know if that helps or you need anything further.


Let me know how it goes.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.