0

Basic Data

  • Graphics Cards: 2x GT 9600
  • Displays: 3x Dell 1907FP @ 1280x1024
  • OS: Linux Mint 17.2 XFCE
  • Nvidia Driver: nvidia-340 (recommended)

I also have a Geforce GT 610, Geforce 8400 GS, Geforce 210, and a Radeon HD 4850 if there is something more compatible. I also have more monitors, but I am very sure that they are not the issue.

Current xorg.conf:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
    Identifier  "Card0"
    Driver      "modesetting"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
    Identifier  "Card1"
    Driver      "modesetting"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

I've read in another thread that I'd need to use another xserver for the other graphics card. Is there some way I can avoid this?

Edited: For readability

  • I would try installing the Geforce GT 610 or 8400 GS card. Then connect all three monitors to the same card. I have ATI and this was the final solution for me instead of hybrid graphics (connected to two cards). The proprietary graphics driver may only support two monitors (on one card) or may support all three. If it supports just two, then I'd research using the xorg driver. Also, if you have more than one graphics card, make sure it is set as the main one in your BIOS. Worst case, you can sell the others and buy an ATI card with three ports. That works great with the open source drivers. – jbrock Jan 4 '16 at 18:40
  • I've tried doing that and while with the GT 610, Mint can see all three screens, it's impossible to activate more than two. I think it has something to do with the fact that the DVI and HDMI are on the same bus?? – Ray Vinmad Jan 4 '16 at 21:02
  • Have you given arandr a try? You can configure (if it works), save it to a script, and set it to run as a Session and Startup > Application Autostart item. – jbrock Jan 4 '16 at 22:23
  • You could buy a cheap ATI card such as the 5450. All three monitors will run on this using the xorg drivers. If you do gaming you can have the center monitor connected via two cables, one to your Nvidia card, the other to the ATI card. You could use arandr to create a script to switch to the Nvidia card when you game and have another script to switch back. Not optimal, but it is an idea. – jbrock Jan 4 '16 at 23:42
  • @jbrock Thanks for the suggestions. I tried the GT 610 with arandr, and I just don't think Linux has the firmware for 3 monitors for that card. The HDMI worked when VGA and DVI weren't in use and vice versa. Arandr works with 3 monitors with the 2x GT 9600!! If you can, make that a post, and I'll mark it as the solution. – Ray Vinmad Jan 6 '16 at 3:49
0

Setting up with arandr

Using the open source drivers and the two GT 9600 cards, install the program arandr. This can be installed by typing:

sudo apt-get install arandr

Use ARandR to configure your screens, save it to a script (Layout > Save As), and set it to run as a Session and Startup > Application Autostart item. (You may need to set it to sleep 5 first before running the layout script.)

Panorama background

I recommend calculating your total screen space (3 of 1280x1024). Your total width is 3840px x 1024px height. Then I would search for panorama images somewhere like Google Images. Then your images can be cropped to fit the overall screen width and height. Right click on the far left desktop > select Desktop Settings > find the directory with your new images > Style (Spanning screens). Your monitors are all the same size. My center one is larger with two smaller same-size ones on the side. You may need to adjust the correct pixel height so the image lines up precisely. This can be done in the script you saved. Here is mine. Note the second pixel value after --pos. (That one side monitor is 4px higher than the other.)

xrandr --output VGA-0 --mode 1440x900 --pos 0x30 --rotate normal --output DVI-0 --mode 1440x900 --pos 3120x34 --rotate normal --output HDMI-0 --mode 1680x1050 --pos 1440x0 --rotate normal 

BIOS setting

I also use three monitors at work. The Dell at work and Lenovo at home both have a BIOS setting where they reserve 1 GB of RAM (given each card is 1 GB). In the Lenovo the BIOS setting is called Surround View. You have two 512 MB cards so your BIOS may be reserving about 1 GB of your RAM. If you have that setting in your BIOS, you can disble it now that you are using the arandr script to load the layout. BIOS Showing 8 GB RAM while Xubuntu only Showing 7 GB

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.