I have researched similar problems, and have not had any success.

I've connected my Sony headsets over Blutooth. "HDMI" and "Headset" are both listed as outputs in the GUI sound settings. It seems HDMI is locked as the default, and clicking on "Headset" does open the option to change settings for Headset, neither can profiles be deleted. Note: My motherboard does not have Blutooth capabilities, so a Blutooth-USB is used.

Sound Settings Locked on HDMI / DisplayPort

Other solutions imply using the Terminal. I've listed the card profiles using

pacmd list-cards

index 0 is "HDA ATI HDMI", alsa_card.pci-0000_01_00.1 index 1 is "HDA ATI SB", alsa_card_pci-0000_00_14.2 index 2 is the headset, bluez_card.[MAC address]

I then tried to set the index 2 card profile to 0.

pacmd set-card-profile 0 output:bluez_card.[MAC Address]

or (using the alias of the device)

pacmd set-card-profile 0 output:MDR-ZX330BT

etc. All commands generated "No such profile"

Next, I tried to set the default output:

pacmd set-defualt-source bluez_card.[MAC address]

again, "No Such Profile". Pressing tab after "set-default source" automatically gives three options, none of which are "bluez"

alsa_input_pci........analog-stereo alsa_input_pci........analog-stereo.monitor alsa_input_pci........hdmi-stereo.monitor

I know this is quite a mess, but any help is welcome.


I have no real answer, but I have made good expiriance to use pulseaudio. If you want you can give it a try with

sudo apt-get install pulseaudio

Hope that helps you.

Regards, Kai

  • Thanks for the answer, however, Pulse Audio is already installed (by default). The command "pacmd" is pulse audio. I think the error might have something to do with the blutooth adapter, or perhaps missing drivers for headphones. – master__blaster Jan 4 '16 at 14:50
  • Oh I was not aware of that, as I', just used the frontend :-/ As you just post a image of the standard sound settings. On my Ubuntu Unity 15.10 pacmd worsk also without puleaudio installed. Mybe you can give the pulseaudio frontend a chance :-) – Kais3n Jan 5 '16 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.