1

Ubuntu 14.04 host is running virtualbox 4.3.34_Ubuntu r104062. There is an ubuntu 15.10 client which, when running, has a small window size. And it will not expand to full window when using the virtualbox -> View -> Switch to Fullscreen. How can this be fixed?

The standard solution to this is to install vboxadditions and reboot, then try it again. (for instance see http://ubuntuforums.org/showthread.php?t=1042494 ) But this does not work.

When I examine the vboxadditions install messages, there is the following:

Verifying archive integrity... All good.
Uncompressing VirtualBox 4.3.10 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 4.3.10 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...done.
Building the shared folder support module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
Installing the Window System drivers
Warning: unknown version of the X Window System installed.  Not installing
X Window System drivers.
 ...done.
Installing graphics libraries and desktop services components ...done.
Press Return to close this window...

I am wondering if the "unknown version" warning in the install has something to do with the issue?

  • If you are using VirtualBox 4.3.34, how and why were you installing the VirtualBox 4.3.10 Guest Additions? – John Scott Jan 2 '16 at 19:12
  • Newer Ubuntu releases may need a new release of Virtual Box as well. Try to upgrade to 5.0.12 – Takkat Jan 2 '16 at 20:01
  • Shortly after VirtualBox 4.3.34 came out, I updated the guest additions, but it left the version at 4.3.10. So I assumed that version was still appropriate. This is the latest VirtualBox in the ubuntu distribution. Upgrading to a non-ubuntu version can cause major problems (I tried that a few months ago and had to downgrade quickly.) – alangh Jan 2 '16 at 23:27
0

The error is clear. The output says The headers for the current running kernel were not found. You have two options. You can either install the VirtualBox Guest Additions using the official Ubuntu package (what I recommend), or you can install the kernel headers and try again. I'm going to provide directions for installing the package. Since the VirtualBox Guest Additions have already been packaged, building them from source yourself is just wasted effort.

Anyway, make sure you have all of the standard repositories for Ubuntu 15.10 enabled in your guest, and then run sudo apt-get install virtualbox-guest-dkms linux-headers-generic. This will install the VirtualBox Guest Additions using DKMS, which means that the modules will automatically be rebuilt whenever you get a kernel upgrade.

  • On the client, where that error occurred, this is a fresh install of 15.10. Checking with "uname -a" shows linux 4.2.0-22-generic . Checking in /usr/src shows a folder for linux-headers-4.2.0-22-generic. So I do not understand that error. It does not make sense to me. – alangh Jan 2 '16 at 23:35
  • The command in your second paragraph worked! The client now has full screen size. – alangh Jan 3 '16 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.