0

I have no wireless connections. We recently switched our internet service provider and I cannot see the new wireless router/modem. This is the output from the wireless info script:

    ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

sven 3.13.0-74-generic x86_64, Ubuntu 14.04.3 LTS, trusty

CPU : Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz Memory : 3835 MB Uptime : 11:24:05 up 23:15, 2 users, load average: 0.03, 0.12, 0.09

lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01) Subsystem: Foxconn International, Inc. Unex DHXA-225 [105b:e044] 08:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader [10ec:5209] (rev 01)

0e:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07) Subsystem: Sony Corporation Device [104d:90a8] Kernel driver in use: r8169

lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 005: ID 04f2:b328 Chicony Electronics Co., Ltd Bus 001 Device 006: ID 0489:e036 Foxconn / Hon Hai Bus 001 Device 003: ID 04f3:0018 Elan Microelectronics Corp. Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~

iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  Interface               Soft blocked  Hard blocked

0: sony-wifi: Wireless LAN no no 1: sony-bluetooth: Bluetooth no no 2: hci0: Bluetooth no no

lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

wmi 19177 0

module parameters ~~~~~~~~~~~~~~~~~~

wmi (2): debug_dump_wdg=N | debug_event=N

nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

State: connected (global) ============================o=======o========o===========o=========o===========o==============o=========== Interface & ID | Type | Driver | State | Default | Speed | Support | HW Addr
============================o=======o========o===========o=========o===========o==============o=========== eth0 [Wired connection 1] | Wired | r8169 | connected | yes | 1000 Mb/s | |

Address:         192.168.0.128
Prefix:          24 (255.255.255.0)
Gateway:         192.168.0.1
DNS:             192.168.0.1

----------------------------+-------+--------+-----------+---------+-----------+--------------+-----------

NetworkManager.state ~~~~~~~~~~~~~~~ [main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true WimaxEnabled=true

NetworkManager.conf ~~~~~~~~~~~~~~~~

[main] plugins=ifupdown,keyfile,ofono dns=dnsmasq

[ifupdown] managed=false

NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~

BU (802.1x) : ssid=BU (802.1x) | mac-address= | ipv4=auto BU Guest (unencrypted) : ssid=BU Guest (unencrypted) | mac-address= | ipv6=auto | ipv4=auto cardboardcastle : ssid=cardboardcastle | mac-address= | ipv4=auto | ipv6=auto Chromecast4211 : ssid=Chromecast4211 | mac-address= | ipv6=auto | ipv4=auto Costello : ssid=Costello | mac-address= | ipv4=auto | ipv6=auto enfield : ssid=enfield | mac-address= | ipv6=auto | ipv4=auto Pote House : ssid=Pote House | mac-address= | ipv4=auto | ipv6=auto PUBLIC ACCESS : ssid=PUBLIC ACCESS | mac-address= | ipv6=auto | ipv4=auto Redzone-C7F0 : ssid=Redzone-C7FO | ipv4=auto | ipv6=auto Rosebud : ssid=Rosebud | mac-address= | ipv6=auto | ipv4=auto wallace : ssid=wallace | mac-address= | ipv6=auto | ipv4=auto ZootCoffeeMobile : ssid=ZootCoffeeMobile | mac-address= | ipv6=auto | ipv4=auto

interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 127.0.1.1 search netgear.com

Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0 192.168.0.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

--- 192.168.0.1 ping statistics --- 2 packets transmitted, 2 received, 0% packet loss, time 999ms rtt min/avg/max/mdev = 0.514/0.525/0.536/0.011 ms

--- 127.0.1.1 ping statistics --- 2 packets transmitted, 2 received, 0% packet loss, time 999ms rtt min/avg/max/mdev = 0.059/0.062/0.065/0.003 ms

iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "en_US.UTF-8")

iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

       - 

iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~

blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~

[/etc/modprobe.d/blacklist-ath_pci.conf] blacklist ath_pci

[/etc/modprobe.d/blacklist.conf] blacklist acer_wmi

modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[wmi] filename: /lib/modules/3.13.0-74-generic/kernel/drivers/platform/x86/wmi.ko srcversion: CED5410F008DC70DF5F064B depends:
parm: debug_event:Log WMI Events [0/1] (bool) parm: debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)

udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1c.2/0000:0e:00.0 (r8169) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth", NAME="eth0"

PCI device 0x168c:/sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0 (ath9k) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan", NAME="wlan0"

Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules : Not Default /etc/rc.local : Default /etc/modprobe.d : Not Default /etc/pm/(cnf|pw|sl) : Default

[/etc/modules] loop

[/etc/modprobe.d] ath10k_core.conf : options ath10k_core skip_otp=y iwlwifi.conf : remove iwlwifi \ (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \ && /sbin/modprobe -r mac80211 mlx4.conf : softdep mlx4_core post: mlx4_en

Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/vmlinuz-3.13.0-74-generic root=UUID=bc1c1071-aa99-418e-b1c1-213195f04050 ro quiet splash vt.handoff=7

dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[ 0.654017] microcode: Microcode Update Driver: v2.00 , Peter Oruba [ 0.654389] audit: initializing netlink socket (disabled) [ 0.815525] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded [ 3.844025] wmi: Mapper loaded [ 5.434947] Bluetooth: BNEP (Ethernet Emulation) ver 1.3

======== Done ========</pre></code>

I would really appreciate it if someone would tell me how to fix this.

ls | grep back; dkms status

backports-20150903 backath10k, 2.0, 3.13.0-74-generic, x86_64: installed

  • Please edit to include ls | grep back; dkms status thanks – Jeremy31 Jan 2 '16 at 20:47
  • You should upgrade your kernel. Before trying anything else, run 'sudo apt-get install linux-generic-lts-wily'. – John Scott Jan 3 '16 at 16:52
0

You don't need backports or the backath10k dkms I made for the AR9485 card to work. So we will remove them

cd backports-20150903
sudo make uninstall
sudo dkms remove backath10k/2.0 --all

Reboot

After reboot your lspci -nnk | grep -iA2 net should show

02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Foxconn International, Inc. Unex DHXA-225 [105b:e044]
    Kernel driver in use: ath9k

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.