0

I installed ubuntu desktop 12.04 with guest additions on virtualbox.
I try to set resolution with custom /etc/X11/xorg.conf config.

Section "Device"
    Identifier "Device0"
    Driver     "vboxvideo"
EndSection

Section "Monitor"
    Identifier "Monitor0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Device0"
    Monitor    "Monitor0"
    SubSection "Display"
        Modes "1440x2560"
    EndSubSection
EndSection

The problem is the following:
Ubuntu allows me to set resolution like "2560x1440", but does not accept resolution like "1440x2560".

It is possible to "hack" this?
Thank you.

3
  • Can't you use the graphical settings to rotate the screen? Jan 2 '16 at 15:08
  • @Zacharee1 in display settions there is only one "rotaion" option - "normal". Jan 2 '16 at 15:10
  • hmm. Have you checked VirtualBox's settings? I haven't used it much, but I know that VMWare has a menu where you set resolutions for the virtual machine. You may have to do that somehow. Jan 2 '16 at 15:12
0

I fixed the problem)

New xorg.conf:

Section "Device"
    Identifier "Device0"
    Driver     "vboxvideo"
EndSection

Section "Monitor"
    Identifier "VGA-0"
    Modeline "1440x2560_60.00"  318.00  1440 1568 1720 2000  2560 2563 2573 2651 -hsync +vsync
    Option "PreferredMode" "1440x2560_60.00"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Device0"
    Monitor    "VGA-0"
    DefaultDepth 24
    SubSection "Display"
        Modes "1440x2560_60.00"
    EndSubSection
EndSection

Also notice that Monitor Identifier changed from "Monitor0" to "VGA-0".
If i don't use identifier "VGA-0" -> config does not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.