0

OK I'm kind of confused here. After I installed Code::Blocks from the website, a little error popped up the top bar. It said that "Error: BrokenCount > 0", and that one of my packages had unmet dependencies. I instantly knew this was Code::Blocks, because I recalled seeing an error when installing it, that it couldn't install the codeblocks-contrib package and some others. I have tried apt-get install -f, and all of the suggestions, and even going into the Software Center and clicking repair, but this launches similar errors that I found in the terminal. Here's my output of sudo apt-get install -f:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  codeblocks-contrib codeblocks-dev gamin libcodeblocks0 libgamin0
  libwxsmithlib-dev
Recommended packages:
  valgrind
The following packages will be REMOVED:
  codeblocks-headers
The following NEW packages will be installed:
  gamin libgamin0 libwxsmithlib-dev
The following packages will be upgraded:
  codeblocks-contrib codeblocks-dev libcodeblocks0
3 upgraded, 3 newly installed, 1 to remove and 0 not upgraded.
9 not fully installed or removed.
Need to get 0 B/5,309 kB of archives.
After this operation, 1,163 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 249992 files and directories currently installed.)
Preparing to unpack .../codeblocks-dev_13.12-3_amd64.deb ...
Unpacking codeblocks-dev (13.12-3) over (13.12-1) ...
dpkg: error processing archive /var/cache/apt/archives/codeblocks-dev_13.12-3_amd64.deb (--unpack):
 trying to overwrite '/usr/include/codeblocks/externaldepsdlg.h', which is also in package codeblocks-headers 13.12-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/codeblocks-dev_13.12-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Please don't use pastebins. Instead, paste the text into your question, highlight the text, and press the {} button. – Olathe Jan 2 '16 at 7:17
-1

Probably would be best to check for a ppa repo or see if it's in Ubuntu repo then sudo apt-get remove it and then sudo apt-get install it.

  • Hey, and thanks for the help. I have tried uninstalling the package, but it seems to not let me: pastebin.com/qGvYfu5E – jadenPete Jan 2 '16 at 7:18
  • @jadenPete try using synaptic package manager to uninstall then re install it after. – Th'Ink-King Jan 2 '16 at 7:19
  • Aww crud. Thought I had synaptic installed but I didnt. Can't install it, because apt-get wants me to fix these dependencies first xD – jadenPete Jan 2 '16 at 7:22
  • @jadenPete Hmm, you should be able to purge the .deb package using dpkg --purge package_name ..... Ensure you're in the directory the .deb package is in. – Th'Ink-King Jan 2 '16 at 7:24
  • I've deleted the .deb's that I installed Code::Blocks with. Want me to sudo dpkg --purge codeblocks? – jadenPete Jan 2 '16 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.