Dears all,

I just installed ubuntu 15.10 on a dell xps 13 (9350). The internal wifi card is currently not supported under linux, so meanwhile I purchased a trendnet TEW-648UBM.

It works "almost" out of the box, except that very often I can not access internet anymore, while the wifi is still connected (according to the network manager).

Then I need to disable wifi/re-enable, or even plug it out & in.

I would post logfiles but I am not sure which is the useful one.

Could you help me ?

as an addon, lspci -v yields:

3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 525a (rev 01)
Subsystem: Dell Device 0704
Flags: bus master, fast devsel, latency 0, IRQ 276
Memory at dc600000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: rtsx_pci

I also tried the solution here: TRENDnet TEW-648UBM 802.11n 150Mbps Micro Wireless N Adapter not working

but when I do that the adapter is not recognized at all anymore

when I disable the wifi I get the following entry in dmesg:

[ 3671.467610] wlxd8eb9728e940: deauthenticating from f0:82:61:7f:06:00 by local choice (Reason: 3=DEAUTH_LEAVING) [ 3671.487345] cfg80211: World regulatory domain updated: [ 3671.487348] cfg80211: DFS Master region: unset [ 3671.487350] cfg80211:
(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 3671.487352] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 3671.487354] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 3671.487356] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A) [ 3671.487358] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A) [ 3671.487360] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s) [ 3671.487362] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s) [ 3671.487363] cfg80211:
(5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A) [ 3671.487365] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)

When I enable it again I get:

[ 3696.695473] rtl8192cu: MAC auto ON okay! [ 3696.705997] rtl8192cu: Tx queue select: 0x05 [ 3697.194423] IPv6: ADDRCONF(NETDEV_UP): wlxd8eb9728e940: link is not ready [ 3697.221099] IPv6: ADDRCONF(NETDEV_UP): wlxd8eb9728e940: link is not ready [ 3698.099333] wlxd8eb9728e940: authenticate with f0:82:61:7f:06:00 [ 3698.110256] wlxd8eb9728e940: send auth to f0:82:61:7f:06:00 (try 1/3) [ 3698.121718] wlxd8eb9728e940: authenticated [ 3698.125993] wlxd8eb9728e940: associate with f0:82:61:7f:06:00 (try 1/3) [ 3698.137456] wlxd8eb9728e940: RX AssocResp from f0:82:61:7f:06:00 (capab=0x411 status=0 aid=4) [ 3698.138237] wlxd8eb9728e940: associated [ 3698.138261] IPv6: ADDRCONF(NETDEV_CHANGE): wlxd8eb9728e940: link becomes ready

if I run dmesg | grep rtl8192

[ 6.371861] rtl8192cu: Chip version 0x10 [ 6.453835] rtl8192cu: MAC address: d8:eb:97:28:e9:40 [ 6.453840] rtl8192cu: Board Type 0 [ 6.453936] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin [ 6.485037] usbcore: registered new interface driver rtl8192cu [ 6.486499] rtl8192cu 1-2:1.0 wlxd8eb9728e940: renamed from wlan0 [ 6.547964] rtl8192cu: MAC auto ON okay! [ 6.560302] rtl8192cu: Tx queue select: 0x05 [ 4197.188439] rtl8192cu: MAC auto ON okay! [ 4197.199672] rtl8192cu: Tx queue select: 0x05

Would any of you have some idea to help, adding the wlx... in /etc/network/interfaces as shown in my comment below did not help

Thx, Timothé

  • What is the internal card? lspci -nnk | grep 0280 -A2
    – chili555
    Jan 1, 2016 at 14:30
  • Hi I would love if somebody can help me to get the internal working, using a usb device is not a solution in the long term for me (only have 2 USB port). result of the command is: 3a:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:43a3] (rev 08) Subsystem: Dell Device [1028:0021] Jan 1, 2016 at 22:35
  • I think your best shot is kernel version 4.4. kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-rc7-wily I can write instructions if you'd like to try.
    – chili555
    Jan 1, 2016 at 23:27
  • Hi, Yes I would enjoy if you have simple instruction on how to install. In the mean time I also found this : github.com/awesomebytes/ubuntu14_dell_xps13_9350 which kind of the say that the latest kernel is not sufficient but also proposes a solution. I tried to contact the guy, unsuccessfully, should his work also work for ubuntu 15.10 (he used 14.04). Thx Jan 3, 2016 at 15:47
  • Since this question is about your USB, please start a new question about the internal wireless and I'll respond. Be sure to include the details: Broadcom Corporation Device [14e4:43a3] (rev 08) Subsystem: Dell Device [1028:0021] Also, please note in the link you gave, he says: "Wifi works..."
    – chili555
    Jan 4, 2016 at 15:51

1 Answer 1


I suggest you remove the addition to /etc/network/interfaces as it is ineffective.

You can install a better driver by running in terminal

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtl8192cu-dkms linux-firmware

and reboot.

  • Hi, thanks a lot, this seems to do the tric for now, but as the timing was a bit random I'll need to work with it a bit more to confirm. However, as I'm using the wily ubuntu your command did not work, so I tweaked it to use the trusty repository instead of the wily. Was this the correct choice or should I better use the wily and install the rtl-wifi-new-dkms instead of rtl8192cu-dkms ? Jan 1, 2016 at 22:33
  • I think, in your circumstance, that rtlwifi-new-dkms may be the better option. Is that what you installed? How does it perform?
    – chili555
    Jan 1, 2016 at 23:23
  • Hello, actually I used the trusty one. I would say it works, but is kind of unstable. sometimes I need to disable/enable the wifi multiple time, unplug replug the USB dongle to get it to work, onces it is connected it is fine. it says it is connected to network "none", and does not want to do differently. I tried the rtlwifi-new-dkms, but with this one the pc does not want to boot, I get a black screen when I should get to the desktop. I tried to unstall/reinstall it but no success. So currently I have something working, but irking sometimes, when it takes 5min to get it connected properly. Jan 3, 2016 at 15:41
  • Comment to myself, the issue connected to network "none" is actually a non-issue, it is still connected and is a network manager bug. Jan 18, 2016 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .