2

According to http://manpages.ubuntu.com/manpages/utopic/man1/gvfsd.1.html gvfsd automatically launches gvfsd-fuse (http://manpages.ubuntu.com/manpages/utopic/man1/gvfsd-fuse.1.html)

I want to know how to get this to automatically specify options when auto launching it. When I try to specify these options myself by running gvfsd-fuse, the options are ignored and the auto-launched instance trumps my manually launched instance.

Edit: if it wasn't clear, the options I refer to are the command line options of gvfsd-fuse

  • I am suspecting that as mentioned in the documentation, specifying the ENV variable GVFS_DISABLE_FUSE may cause my manually spawned instances to take precedence. This is one approach I haven't tried yet. I will try it when I have some time. – Nuzzolilo Jan 1 '16 at 19:28
  • I ended up working around the problem by using "sudo mount -o user=Admin,password=[password] //[ip] ~/mount" and then doing all of my work with that drive as root. Kludgey at best but better than trying to use gvfs-mount and getting an unconfigurable mount location that has commas and equal signs in the path (which breaks my compiler) – Nuzzolilo Jan 1 '16 at 21:00
0

The command smbnetfs is a great way to mount a samba share, while exposing plenty of configuration options. In my case, since I was mounting a samba share, the options I was looking for (allow_other in my case) was exposed by this command smbnetfs.

This doesn't directly answer the question though, but it's possible that someone who finds this may be trying to do the same thing I was doing. I will leave the question open in the hopes that someone will have figured out a way to directly do what is being asked (since a user may want this question solved for other reasons which this workaround does not solve).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.