3

I've already asked on the Qt forum, but apparently Ubuntu users aren't there.

Steps to reproduce:

  1. Place the cursor somewhere.
  2. Scroll down with a mouse wheel so the cursor is not in sight any more.
  3. Select some text.
  4. Start scrolling up or down with the mouse wheel.

And instead of scrolling, it jumps up for a big amount.

3.5.1 or 3.1.1

Is it a bug? Is there a workaround?

1

From https://bugreports.qt.io/browse/QTBUG-59764

The problem is somehow related to the Logitech G300 mouse.

Same: https://bugs.freedesktop.org/show_bug.cgi?id=97510

G300 is two devices: mouse and keyboard. Looks like the keyboard events confuse the input system.

Workaround that fixes scrolling, but disables most of additional buttons (depending on how they are programmed):

Section "InputClass"
    Identifier "Ignore keyboard mouse device"
    MatchIsKeyboard "on"
    MatchProduct "Logitech Gaming Mouse G300"
    Option "Ignore" "on"
EndSection
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.