I'm trying out some different desktop environments to find the one that works for me, and right now I'm really liking Cinnamon.

I'm having only one strange problem, though. When I try to connect to my openVPN server using the GUI drop down interface in the panel, it refuses to connect. When I click to turn on VPN, it flickers to "on" for not even a second, but then immediately goes back to "off".

VPN connection in Cinnamon

How can I diagnose and fix this problem? It seems to be limited to just Cinnamon, though I can't understand why a desktop environment would treat VPN differently.

Update: I found this error by running sudo tail -f /var/log/syslog:

NetworkManager[636]: <error> [1451684252.150609] [vpn-manager/nm-vpn-connection.c:1980] get_secrets_cb(): Failed to request VPN secrets #3: (4) No agents were available for this request.

I looked it up on the internet, and found suggestions that I should clear out the /etc/NetworkManager/system-connections/ directory, reinstall network manager with sudo apt-get install --reinstall network-manager, and then reinstall Private Internet Access. Unfortunately, none of this helped and the problem persists exactly as before. The same error message in syslog still occurs after having taken all these steps.


Maybe some of the following can help:

Reinstall following package:

sudo apt-get install network-manager-openvpn-gnome

PIA-Ubuntu OpenVPN

When in Cinnamon have you tried manually adding a OpenVPN connection or importing a saved VPN configuration from Network Connections?

To import a saved VPN configuration go into:

  1. Network Connections. Click Add.
  2. Select: Import a saved VPN configuration. Navigate to where the .opvn file is (usually /etc/openvpn). If you can't find the .opvn files (or don't have them) on your system: https://www.privateinternetaccess.com/openvpn/openvpn.zip

  3. Gateway and CA cert may have entries filled in, along with other provider specific details in Advanced settings. Note "Connection name" (not Gateway) or change it to something that stands out for you e.g. "testLondon" if you picked a London gateway.

  4. Enter your User Name and Password (you can choose to store it or ask every time) from PIA and save.
  5. While connected to the internet select this new connection e.g. "testLondon" from your drop down menu, depending on your settings it may or may not ask for your VPN password.
    An attempt to connect to your Gateway will be made and a un/successful notification should pop up.

After seeing your error log and trying the following, the Cinnamon GUI did seem a little glitchy but if it's not a username/password problem then I have no idea what it is.

So I finally found a friend with PIA and installed Ubuntu 15.10 with Cinnamon on a VM:

After a base Ubuntu 15.10 install, I installed Cinnamon using package:
updated the entire system and rebooted into Cinnamon desktop then followed PIA-Ubuntu OpenVPN, after installing relevant packages it asks for username (or rather number).

When the script was finished I got the same GUI that you've posted. I then clicked the VPN Connections toggle switch to ON and then it immediately turns OFF (I expected this as I had no password for any VPN gateway, so there was no default VPN gateway to connect to).

I then selected "PIA-AU Melbourne" from the list and a "Authenticate VPN" dialog box pops up, I entered the password and a few seconds later got a system notification telling me that the VPN connection has been successfully made. A white dot appears in front of "PIA-AU Melbourne" in the GUI list. I checked the ip and yes it's Australian. I then checked PIA's site and yes it's a PIA ip. Success so far.

I wanted to log what was going on for the next connection so I clicked the VPN Connections toggle switch to OFF and ran sudo tail -f /var/log/syslog I clicked the VPN Connections toggle switch to ON and it connected to "PIA-AU Melbourne" straight away (no dialogue box as the password is now stored in the keyring). No problems in syslog.

With syslog still running I then selected a different gateway, "PIA-Brazil", the password dialogue box came up again but I selected cancel and got a similar error log as you did in syslog (). I selected "PIA-Brazil" again, input password and no problems again. So the only thing I can think of in your case is a username/password problem.

If the password dialogue box (probably the user agent) didn't pop up for you, after running the PIA Ubuntu script again, go to Network Setting from the GUI in your picture and select any PIA profile e.g. "PIA-AU Melbourne VPN" and go into its settings and check if your password is in there (your username and other settings should already be in there because of the PIA Ubuntu script). Then select that gateway from the GUI in the pic. Maybe try it out in a VM first

  • Thank you for responding. Unfortunately, the problem persists. I already had the package installed, and the instructions on Private Internet Access's site did not change anything. I don't know how to implement your last suggestion of manually adding an OpenVPN connection or importing a configuration. – Questioner Jan 1 '16 at 9:24
  • When you click an individual connection say "PIA - UK London" as opposed to the on/off "VPN Connections" switch, what happens? Does it ask for your PIA password/connect automatically (because you previously entered and saved a password for that connection) or does it do nothing? You can check your ip on privateinternetaccess.com to see if you're connected. Thanks MicrosoftLinux for the format :) – rustynuts Jan 1 '16 at 17:11
  • The same thing happens if I click on one of the access points. I don't get prompted for a password. The drop down goes away and I'm not connected. – Questioner Jan 1 '16 at 21:29
  • Please also note the updated information in my question. – Questioner Jan 1 '16 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.