1

This question already has an answer here:

I'm trying to install the lastest version of ceph on my armhf platform. I have already updated my installed release of ubuntu to the latest development of Xenial.

problem is, everytime i check, i find ceph version 0.94.5 (hammer) available for download. but when i check the actual repository at ports.ubuntu.com, i find version 9.2 (Infernalis) available. but the packages.[gz,bz2] file always lists version 0.94.5 instead.

what's the reason for this, and how can I fix this to install the latest available version ?

to explain that my questions is different from the proposed, i'm asking about the newest release which is already available in the repository. Thanks!

marked as duplicate by muru, Eric Carvalho, Ravan, David Foerster, Mark Kirby Jan 2 '16 at 14:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This is a different issue, as the newer package versions mentioned are already available in the repository. just not updated in the packages file. – hp cre Dec 31 '15 at 23:24
  • You'll find them in the Packages files for xenial-proposed, that's to say, they're in testing for an unreleased version of Ubuntu. As such, the question is the same. You're right about Ceph not supporting armhf by themselves, sorry about that. – muru Dec 31 '15 at 23:36
  • you're right. last time i checked a couple of days ago they were still listed 0.94.5. – hp cre Dec 31 '15 at 23:55
  • 1
    Enable proposed and you should be good to go, though: askubuntu.com/questions/49609/… It can't be any more riskier than running 16.04 itself. – muru Dec 31 '15 at 23:57
1

muru's point is right. It is now available in the Xenial proposed section. it wasnt like that a couple of days ago.

Not the answer you're looking for? Browse other questions tagged or ask your own question.