0

Fresh Ubuntu install and I'm brand new to Linux. I need help getting connected to the internet. There's no options for wifi to connect and when I plug in an ethernet cable nothing happens. When I run ifconfig I only see lo listed. How do I just connect this darn thing to the internet?!

Also, see attached picture for what happens when I enter lspci -vnn | grep '\[02.0\]'

enter image description here

I have also now attached a picture with the commands that you requested I run. I haven't installed anything except for Ubuntu so I'm assuming I need drivers but I can't connect to the internet and when I try to install via disk I get an error because it is a windows driver.

enter image description here

  • Please edit your question to include the output of the command lspci -vnn | grep '\[02.0\]' (which will - hopefully - identify the network adapter hardware) – steeldriver Dec 31 '15 at 21:36
  • I'd suggest to include sudo rfkill list and sudo lshw -c network into your question. Chances are you have network cards that are either blocked by rfkill or don't have drivers for that. – Sergiy Kolodyazhnyy Dec 31 '15 at 23:42
  • If you have an Intel wifi card, Google "iwlwifi [wifi card model]" to find a driver for it, that may be the problem. Is there no Ethernet port? – zwork Jan 1 '16 at 1:07
  • The internal card is a Killer AC 1535. I also have plugged in an external USB wireless card that is a Netgear A6210. As previously stated, there is an ethernet port and when an ethernet cable is plugged in nothing happens. When I boot the same computer into windows all three internet options (internal wireless, external wireless card and ethernet) all work properly. – Brent Kiomall Jan 1 '16 at 1:23
  • I also have the cd with the Netgear A6210 drivers but since they are for windows, when I click on it to open the "Autostart.exe" I get an error that says "An error occurred while loading the archive". So then I find out I need something called Ndiswrapper?? How do I get this on the machine? Do all linux users go through this? – Brent Kiomall Jan 1 '16 at 1:34
1

first, i suggest you run lspci as root using "sudo lspci ..." and pst back the output.

If still nothing shows up then there is a problem with your ethernet card or wifi card.

if something shows up but you cant see any adapters when you run "sudo ifconfig -a" then there are missing drivers.

please post the output of both commands mentioned above first, then we can discuss next steps

|improve this answer|||||
  • I added a photo of the output above. Thank you for your help! – Brent Kiomall Jan 1 '16 at 1:35
0

Ok thanks. Based on the commands you run, i would have to say that it's strange that nothing came up in lspci. Anyway, if let's say we want to configure the Killer ac card, here is the procedure to do it killer ac 1535 driver install

Please try to download all these files from your windows installation onto a usb drive or so. Then boot into Linux and follow the instructions.

Do you know which chip you have for ethernet ? You can post the output of

dmesg

So we can look at all the boot messages and determine what Linux actually sees in your hardware.

|improve this answer|||||
  • Hi hp cre, while you are allowed to add multiple answers to one question, the better way if you are not offering different solutions would be to edit your first answer. – bummi Jan 1 '16 at 8:46
  • Gave up on Linux for a while but now I'm trying to get it working again. I tried all the above suggestions and nothing works. Any ideas? I'm literally just trying to connect to the internet. – Brent Kiomall Feb 13 '16 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.