1

I have a weird problem where a laptop's (X)Ubuntu install refuses to boot. It has worked for over a year without any issues, doesn't have any fancy GPU or other driver requirements at all and has worked out of the box since installed until recently.

The behaviors it exhibits when trying to boot normally are as follows:

  • GRUB is always reached.
  • Booting into the normal Xubuntu desktop always fails.
  • For the brief moment when it switches from GRUB to the splash we can see it printing ^[[18~ (or some other truncation, it's hard to tell) repeatedly on the screen without any linebreaks of anything.
  • The splash flashes intermittently from black screen as the spinner animates.
  • The splash never terminates, nor does the desktop boot.

Trying to boot from a liveUSB does the following:

  • Still prints ^[[18~ repeatedly.
  • Splash still flashes as it animates.
  • Never terminates, never boots.

As a result, I can't even give up and install over it because no liveUSb would boot (I tried Ubuntu, Xubuntu, 14.04, and Elementary Freya 0.3!)

Additionally, and inconsistently, it sometimes it boots into recovery mode. Still exhibits the following behavior:

  • Still prints ^[[18~ repeatedly while it boots.
  • But reaches the boot menu eventually. But not ALWAYS!
  • Fsck doesn't return any errors.
  • If it ever reaches the recovery menu, booting can be resumed to the normal desktop. But no matter how many times we've tried, normal boot never works.
  • From the resumed desktop of the recovery menu, Palimpsest shows no disk errors either.

And finally, the laptop is dual booted with Windows 7. They have coexisted for over a year without any issue. Windows also has no issues whatsoever when booting or otherwise.

This is what that wall of ^[[18~s looks from a chance shot as it promptly switches to the flashing splash and gets stuck: screenshot

I haven't a clue!

1 Answer 1

1

The F7 key is probably stuck with dirt or something.

1
  • That's what it is isn't it! It'll be a day until I get access to that laptop again, so I'll be sure to make sure. But what does the F7 key do that would stop it from booting? Ctrl+Alt+F7 is the default graphical session, but we're not pressing any of those keys, though.
    – Scio
    Jan 1, 2016 at 4:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.