4

Ubuntu 15.10 64bit

When moving or copying files to either a USB Pen Drive or a Network Share Drive Nautilus (Files) hangs. The copying/moving process starts but then freezes. I know Ubuntu cannot handle large files, however, the file I am moving is only 922MB (.MP3).

I've tried using the cp (copy) command in terminal but now the terminal hangs. A file does sometimes copy, but a file this size can sometimes take up to 30 mins.

I have tried both on a wireless and hard wired network connection.

I have no internal Firewalls.

I can copy to the Network Share Drive, which is on a PC running Ubuntu 14.04.3LTS using SAMBA, from my Win7 PC with no issue and from an old laptop running Linux Mint17.

When looking at System Monitor, I am barely using any CPU or Memory when this issue occurs, so it does not appear to be a lack of memory, etc.

  • Any chance, your USB Pen Drive is degraded? Have you scanned it? – Tung Tran Dec 31 '15 at 3:13
  • USB Pen Drive is new. I reformatted it to FAT32. – pst007x Dec 31 '15 at 3:51
1

This is very odd that you're seeing it with all of your attempted tools (Nautilus, cp etc.) and that you're seeing it on both USB and Samba shares. That's suggestive that something else is going on. I would recommend installing iotop (must be run under sudo/root):

$ sudo apt-get install iotop
$ sudo iotop

This will help you get an idea for what's going. If things look like they're hanging you could throw in a 'sync' command to see if something is getting hosed up with the file getting stuck.

$ sync

Also using:

$ top

Can allow you to monitor the process to see if it's hanging.

Finally, I use rsync for my network transfers (for a variety of reasons like the ability to resume and to view progress) so you may want to explore using rsync.

$ rsync -v --progress /path/to/myfile /path/to/destination/

There are other reasons you could see this too that could be related to hardware or impending hardware failures.

0

I think it may be a bug, I read that gvfsd-trash uses excessive CPU usage, though I did not record this. However, by limiting gvfsd-trash cpu usage I found it resolved the issue. So, hopefully future updates may resolve this issue.

I used this here to limit this process, seemed to work for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.