6

I have a Windows 10 machine installed on an SSD, installed another hard disk and I installed Ubuntu 15.10 on it. I didn't specified anything when installing, but now it boots directly into Ubuntu. It doesn't give me the option to select which OS to boot.

  • Quick question, what do you mean on another hard disk? – geekseradicateall Dec 31 '15 at 2:49
  • I installed Ubuntu on another physical hard disk, different than the drive that I installed Windows on. – superkinhluan Dec 31 '15 at 4:39
  • Which hard drive is the "first", from the point of view of the BIOS? Does swapping the cables over cause Windows to boot again? – pjc50 Dec 31 '15 at 12:10
  • There's so much that could be wrong. What is your current drive schema? (sudo fdisk -l and sudo gdisk -l) The output of sudo os-prober. And what is the desired behavior? That you boot into UEFI? GRUB? or just whatever allows you to select what OS to boot from? – Braiam Dec 31 '15 at 13:51
  • We really need to know if UEFI or BIOS or mixed mode boot. Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info You can run from a working Ubuntu install or from LIve installer. – oldfred Dec 31 '15 at 15:11
1

First try to go into your Terminal Ctrl+Alt+T.

Next type in:

sudo grub-install

wait for that to finish, then do:

 sudo grub-update

Finally restart your computer and see if the windows 10 shows up in the boot menu, it might say windows 8 loader which is what mine says.If that doesn't work I will look for something else.

  • Thank you for your answer. When I tried to run "sudo grub-install", I got this error message "Install device isn't specified." what does that mean? – superkinhluan Dec 31 '15 at 4:28
  • @superkinhluan you must specify the device: sudo grub-install /dev/sda – wb9688 Dec 31 '15 at 6:47
1

You have one of two options, here they are:

Option 1. Type Ctrl+Alt+T

and type in the following command

sudo grub-install

once that finishes do:

sudo grub-update

now restart your computer and you should see a list of operating systems..

Choose whichever you prefer / want.

-

Option 2. Power off, and then turn on your computer..

While it is turning on press the f12 button on your keyboard.

You should see a list where you can select windows (using your arrow keys)!

Good luck!

  • Thank you for your answer. When I tried to run "sudo grub-install", I got this error message "Install device isn't specified." I then tried Option 2, but it still boots directly into Ubuntu. – superkinhluan Dec 31 '15 at 4:37
  • One moment let me figure out why – Trevor Clarke Dec 31 '15 at 4:38
  • 1
    @superkinhluan try this: sudo grub-install /dev/sda – Trevor Clarke Dec 31 '15 at 4:39
  • 1
    @superkinhluan then do sudo update-grub – Trevor Clarke Dec 31 '15 at 4:40
  • 1
    Sudo Sudo? what... – Star OS Dec 31 '15 at 7:55
0

Enter the boot menu when you're at POST screen and choose your SSD, it should boot into Windows 10 as long as you didn't modify the MBR. You can as well edit the default boot drive in your BIOS.

  • My SSD doesn't appear in the list. :( – superkinhluan Dec 31 '15 at 11:33
  • Can you see your SSD in the BIOS? – Aodai Dec 31 '15 at 16:14
  • yes, I can see it. – superkinhluan Dec 31 '15 at 21:59
  • Change the boot order so your PC would boot into the SSD instead of the HDD. – Aodai Jan 1 '16 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.