I'm currently running a relatively fresh installation of Ubuntu GNOME 15.10 on a notebook connected via Wifi. Other network interfaces are present (mobile broadband, ethernet) but apart from the lo interface not connected.

When running dig example.com or dig @ example.com the query times out while host example.com works fine.

The network routes fetched via route -n look fine to me. As far as I'm aware there are no filters present on this network.

I've used Debian from only command line for a few years, but I'm quite new to Ubuntu - especially with a graphical shell. I'd appreciate your help!

2 Answers 2


The timeout of the response from in your network maybe greater than 15s, the default timeout of dig command. You can use +time to set the timeout for a query to n seconds. The default timeout is 5 seconds. And also use +tries set the number of times to try UDP queries to server to n instead of the default, 3:

dig +time=10 +tries=5 @ example.com
  • Sadly this does not solve the issue. DNS queries are answered in a matter of a fraction of a second. Also there would be a noticeable delay when using host against unknown domains, which is not the case.
    – K.A.B.
    Dec 31, 2015 at 13:31
  • Appending the +tcp flag to the dig command let's me query DNS records. Now the question is why that's the case and how to fix that since other UDP based applications work just fine.
    – K.A.B.
    Dec 31, 2015 at 14:24

O.K. something weird is going on here. This problem is not Ubuntu related, but caused by some sort of weird network filtering on the network I'm using. As to why this is or what causes this I have no idea.

Apperently UDP based DNS lookups are blocked on the AP I was connected to or by the ISP. Appending the +tcp flag to dig fixed that and so does changeing the network (I couldn't try that before due to the lack of an alternative).

From what I can tell from here the ISP is Versanet (Germany) and the network uses both gear from TP-Link and Netgear. Since this is not my network I probably cannot really dig much further here.

Thank you Tung Tran for your help anyway.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .