0

I just bought an Acer Aspire E15 (E5 573G-71L9) with an NVIDIA Geforce 940M, Intel Core i7-5500U processor, 15.6'' FHD LED LCD, and Windows 10 Home pre-installed. The default boot method is UEFI - Secure Boot.

I created 700 GB free disk space by shrinking the Windows partition in Windows 10. I created a bootable USB stick using the Startup Disk Creator in Ubuntu with an ISO of Ubuntu 15.10 64-bit (the checksum is correct).

After having changed the boot order to have the USB stick first, I got the GRUB2 menu. After selecting 'Trying Ubuntu without installing', I got a blank/black screen. The 'working light' on the USB stick did not flash anymore, indicating that nothing was happening.

I tried the following proposed fixes, without success: - Replacing 'quiet splash' with 'nomodeset' (assuming it was the graphic card) - Using an external monitor (for the same reason, using both 'quiet splash' and 'nomodeset') - Setting the boot method to 'Legacy' (no valid boot device was found) - Disabling 'secure boot' in UEFI (still blank screen after grub) - Adding the two files in BOOT/EFI (or was it EFI/BOOT..) to trusted boot methods and putting them on top of the boot order (still blank screen after grub)

With that, it looks like I covered virtually all suggestions given in 'similar questions' and I have no clue how to continue. Suggestions, pointers to similar questions that I may have missed and other help would be much appreciated. Thanks.

Update 1 January 2016: in addition, I tried to run the live USB of Ubuntu 14.04 LTS and Mint 17.3 (normal and compatibility mode). I also burned Ubuntu 15.10 on a DVD. In all cases, after having selected an option from the menu, I got a black screen. Both the CPU and the graphic card are used in 'Ubuntu certified systems'.

Are there any tests that I can carry out to find the probable cause of the black screen?

  • Do you mean Syslinux menu? GRUB2 does not (or should not) show up when booting the Live system. – Eduardo Cola Dec 30 '15 at 23:47
  • I did mean the Grub2 menu (the purple menu) that allows users to choose between 'Trying Ubuntu without installing' and 'Install Ubuntu'. As far as I know, this is the normal menu when booting from a Live USB - I have seen this, and used this, several times before on different notebooks (without UEFI, though). On one occasion (after some changes in the BIOS, I can't remember exactly which, unfortunately), I got the Syslinux menu, though, followed by the blank/black screen as described. No further clues, alas. – Eelco Herder Dec 31 '15 at 0:59
  • Yep, that's the Syslinux menu, not the GRUB menu. Have you tried removing all kernel parameters before booting (boot without 'quiet splash')? – Eduardo Cola Dec 31 '15 at 1:09
  • Thanks for the suggestion. I tried to boot with all kernel parameters removed. Still nothing. – Eelco Herder Dec 31 '15 at 13:13
  • It looks like I am able to install OpenSuse (but that's not what I want/need), so it seems it is an Ubuntu-specific issue (erm, Ubuntu-AcerE15-specific issue). Doesn't anyone have a clue or a suggestion how to continue pinpointing the problem? A black screen is not a very helpful starting point. Thanks again! – Eelco Herder Jan 2 '16 at 12:47
0

This answer was given in the Acer community: "Have you installed the latest BIOS?"

Updating the BIOS from version 1.25 to 1.31 did the trick indeed. The reason is that version 1.25 did not support Linux at all (probably a bug).

It still did not work out of the box: I had to manually add \EFI\ubuntu\grubx64.efi to the boot sequence in order to get the GRUB menu (the entry was not automatically added).

So now I have a working Ubuntu environment. But... the wireless lan is not working. I will have to look into that tomorrow, but looking at the first quick search results, it seems that the network card is not supported...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.