0

I have a dual-boot of Ubuntu 14.10 and Windows 10.

No networking issues are present after booting to Windows.

Whenever I boot into Ubuntu, however, I cannot connect even to my router (ZTE ZXDSL 931VII). DHCP seems not to grab an IP (I never get an ipv4 address and ipv6 only gets the MAC-based autoconfigured one), although tcpdump does list some (I assume outgoing) ARP and other UDP packets.

Previously the wired connection was working, however since I didn't boot for a few months, I'm not sure when this issue started. I assume it's probably due to some updates. :-/

Wireless connection, btw, does work without any extra configuration.

I've tried several things which did not fix the problem (top to bottom):

  • Rebooting
  • ifconfig eth0 up and down
  • Configuring DNS servers to 8.8.8.8 and 8.8.4.4
  • Reconfiguring DHCP (dhclient.conf)
  • Specifying variations of auto eth0 and iface eth0 inet[6] dhcp in /etc/network/interfaces (ended up rendering the eth0 iface unmanaged)
  • Changing my hostname
  • Manually setting up a static ipv4 address
  • Disabling ipv4, enabling ipv6 and vice versa
  • Removing docker interfaces
  • Various other settings through the network manager GUI

In short, everything looks normal from the configuration standpoint and I feel that I've pretty much exhausted my attempts to repair this.

As I see it, no IP connectivity is achieved whatsoever. I didn't bother probing the router via MAC.

I also didn't try updating drivers or any related software, but I will post back here once I do.

This is my network card:

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
Subsystem: Gigabyte Technology Co., Ltd Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 74
I/O ports at b000 [size=256]
Memory at fe600000 (64-bit, non-prefetchable) [size=4K]
Memory at d0000000 (64-bit, prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
Capabilities: [d0] Vital Product Data
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
Kernel driver in use: r8169

ifconfig gives me:

eth0      Link encap:Ethernet  HWaddr 74:d4:35:xx:yy:zz  
      inet6 addr: fe80::76d4:35ff:fexx:yyzz/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:1440 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

When I check the state of the network card, it shows link detected.

$ ethtool eth0

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
               drv probe ifdown ifup
Link detected: yes

Any ideas?

  • I have just upgraded to 15.04. Seems that didn't do the trick. I still cannot connect via wired eth. – kburnik Dec 31 '15 at 0:53
1

Seems like a dire monologue, however I seem to have fixed the issue.

The problem was with the drivers for Realtek ethernet card most probably imposed by an update I fail to remember taking place.

I realized the drivers installed were r8169, however r8168 are the ones that should be installed.

The solution is to download the most recent drivers for your kernel (mine being 3.x.x) and install them.

Realtek r8168 drivers (Linux): http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

See README file inside for installation instructions.

After installation, make sure to reboot.

If one needs to remove the r8169 manually from the kernel modules, one can do so by:

sudo modprobe -r r8169

Still no internet?

Check /etc/resolv.conf (Adding 8.8.8.8 and 8.8.4.4 for nameservers should fix the issue).

Hope it saves someone a couple of hours. :-)

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.