0

I follow this link link to install Oracle 11g XE on Ubuntu 14.04.After Following all the steps, still it is showing following problems:

~$ sudo /etc/init.d/oracle-xe start
Starting Oracle Net Listener.
Starting Oracle Database 11g Express Edition instance.
Failed to start Oracle Net Listener using /u01/app/oracle/product/11.2.0/xe/bin/tnslsnr and Oracle Express Database using /u01/app/oracle/product/11.2.0/xe/bin/sqlplus.

whenever i try to open oracle on web browser, oracle remain unable to install.

http://localhost:8081/apex/f?p=4950

BTW I have also XAMPP installed in my pc.

updates: after is installation i did this, But still oracle Not works.

usr@pc: cd /u01/app/oracle/product/11.2.0/xe/bin
usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ lsnrctl start

LSNRCTL for Linux: Version 11.2.0.2.0 - Production on 01-JAN-2016 13:03:31

Copyright (c) 1991, 2011, Oracle.  All rights reserved.

Starting /u01/app/oracle/product/11.2.0/xe/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 11.2.0.2.0 - Production
System parameter file is /u01/app/oracle/product/11.2.0/xe/network/admin/listener.ora
Log messages written to /u01/app/oracle/diag/tnslsnr/usr-pc/listener/alert/log.xml
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC_FOR_XE)))
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=usr_pc)(PORT=1521)))

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC_FOR_XE)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version 11.2.0.2.0 - Production
Start Date                01-JAN-2016 13:03:31
Uptime                    0 days 0 hr. 0 min. 0 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Default Service           XE
Listener Parameter File   /u01/app/oracle/product/11.2.0/xe/network/admin/listener.ora
Listener Log File         /u01/app/oracle/diag/tnslsnr/usr-pc/listener/alert/log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC_FOR_XE)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=usr-pc)(PORT=1521)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
  Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
The command completed successfully

usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ sqlplus
Error 46 initializing SQL*Plus
HTTP proxy setting has incorrect value
SP2-1502: The HTTP proxy server specified by http_proxy is not accessible
usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ echo $http_proxy
localhost

Latest Updates:

 usr@pc:himadree@himadree-Inspiron-1545:/u01/app/oracle/product/11.2.0/xe/bin$ export http_proxy=http://localhost
usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ echo $http_proxy
http://localhost
usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ sqlplusError 46 initializing SQL*Plus
HTTP proxy setting has incorrect value
SP2-1502: The HTTP proxy server specified by http_proxy is not accessible

with unset proxy But still same error:

usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ unset http_proxy
usr@pc:/u01/app/oracle/product/11.2.0/xe/bin$ echo $http_proxy

usr@pc::/u01/app/oracle/product/11.2.0/xe/bin$ sqlplus
Error 46 initializing SQL*Plus
HTTP proxy setting has incorrect value
SP2-1502: The HTTP proxy server specified by http_proxy is not accessible

Error image http://localhost:8080/apex/f?p=4950

it is already been 9 times failed attempt to install oracle 11g.I am mentally exhausted. please suggest me,how can i fix it.please let me know if any further information is required. Thanks :)

1
  • It appears your listener is starting so you are actually really close. I believe http_proxy needs the http:// so the for mat to: http:// localhost / or just unset it entirely (it is not required). See if that makes any different.
    – snorp
    Jan 2, 2016 at 1:11

1 Answer 1

0

This is probably an off topic question and really more of a question for the Oracle Community but there are a few things you need to check. First, make sure you set all the environmental variables correctly (such as ORACLE_HOME) something like one of these should show you the path that is currently set but make sure it is correct by doing an ls on whatever the path is shown:

$ /usr/bin/env |grep ORACLE
or use:
$ echo $ORACLE_HOME

Next, you can try to manually start the listener and replace [listenername] with your listenername store in listener.ora (found under $ORACLE_HOME/network/admin/ usually):

/usr/lib/oracle/xe/app/oracle/product/11.2.0/server/bin/lsnrctl start [listenername]

Note: the default path is /usr/lib/oracle/xe/app/oracle/product/11.2.0/server/bin/lsnrctl, however yours may be different since your path above is looking for /u01/app/oracle/product/11.2.0/xe/bin

If you can get the listener started then try to connect using sqlplus:

$ sqlplus
SQL> CONNECT SYS as SYSDBA

I'm guessing if the installation completed without error (you can check the logs) that it's probably just ORACLE_HOME is set wrong but the logs will reveal the kind of specific error messages that will really help you trouble shoot this. Hope this all helps.

12
  • Thanks @snorp i got error on this /u01/app/oracle/product/11.2.0/xe/bin$ sqlplus Error 46 initializing SQL*Plus HTTP proxy setting has incorrect value SP2-1502: The HTTP proxy server specified by http_proxy is not accessible Dec 30, 2015 at 17:32
  • Did the listener start okay? That's probably the bigger issue. Do you have http_proxy set? (echo $http_proxy) it shouldn't need to be unless you're using a proxy so maybe do an ( unset http_proxy OR set it to localhost: export http_proxy=localhost )
    – snorp
    Dec 30, 2015 at 18:47
  • Thank @snorp for your reply. I followed your suggestion and updated my post above.still i am facing some error.Thanks Jan 1, 2016 at 7:13
  • I just realized that it formatted my comment wrong, I posted above but basically the http_proxy needs the http:// then the hostname:port. You also could just unset it.
    – snorp
    Jan 2, 2016 at 14:00
  • Thank you @snorp for your continuous reply.I am following your comments.I have add latest updates on my post.Please can you check it.Thanks.BTW i want to say, xampp is on localhost.do you think it can be problem.Thank you so much. Jan 2, 2016 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .