0

I'm running old Ubuntu Server 13.04 (raring), and trying to upgrade or even install any packages I'm getting the following error:

root@oem-mobilidade:~# sudo apt-get upgrade -y
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Configurando fontconfig (2.11.0-0ubuntu4.1) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 fontconfig
E: Sub-process /usr/bin/dpkg returned an error code (1)




root@oem-mobilidade:~# cat /var/log/fontconfig.log
/usr/share/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/truetype: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/truetype/ttf-dejavu: caching, new cache contents: 21 fonts, 0 dirs
/usr/X11R6/lib/X11/fonts: skipping, no such directory
/usr/local/share/fonts: caching, new cache contents: 0 fonts, 0 dirs
/.local/share/fonts: fc-cache: symbol lookup error: fc-cache: undefined symbol: FcStrListFirst

PS: Sorry for the portuguese output.

I read some articles telling to purge fontconfig package and reinstalling it, but I'm afraid of doing this because of this:

The following packages will be REMOVED:
  ca-certificates-java* cacti* cacti-spine* default-jre-headless* fontconfig* fontconfig-config* icedtea-7-jre-jamvm* libcairo2* libfontconfig1* libgd2-xpm* libpango1.0-0*
  librrd4* libxft2* openjdk-7-jre-headless* php5-gd* rrdtool* tomcat7* tomcat7-admin* tomcat7-common* tomcat7-docs* tomcat7-examples*

This server runs several applications, like Cacti, and other web based tools that depends on apache, tomcat, php, etc, so I'm worried about removing those packages above.

Please, help!!!

  • 3
    You should be more worried about using a vulnerable, unsupported, with no security updates OS for over a whole year now. – xangua Dec 30 '15 at 16:21
  • I agree, but I need to get it to work first, then upgrade OS. – gugabguerra Dec 30 '15 at 16:43
  • What is in "/var/log/fontconfig.log" ? 13.04 is beyond EOL so support is limited at best. – Panther Dec 30 '15 at 17:29
  • /usr/share/fonts: skipping, existing cache is valid: 0 fonts, 1 dirs /usr/share/fonts/truetype: skipping, existing cache is valid: 0 fonts, 1 dirs /usr/share/fonts/truetype/ttf-dejavu: skipping, existing cache is valid: 21 fonts, 0 dirs /usr/X11R6/lib/X11/fonts: skipping, existing cache is valid: 0 fonts, 0 dirs /usr/local/share/fonts: skipping, existing cache is valid: 0 fonts, 0 dirs /root/.local/share/fonts: skipping, no such directory /root/.fonts: skipping, no such directory fc-cache: symbol lookup error: fc-cache: undefined symbol: FcStrListFirst – gugabguerra Dec 30 '15 at 19:31
  • 1
    Close voters: Issues upgrading Ubuntu are not off-topic! – Seth Dec 30 '15 at 20:19
2

SOLVED!!! Downloaded fontconfig.deb package from DEB PACKAGE HERE and reinstalled with

dpkg -i fontconfig_2.10.1-0ubuntu3_amd64.deb

Now apt-get is working fine and I can upgrade my OS. Thanks guys!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.